summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2016-02-19 14:13:47 +0200
committerMantas Mikulėnas2016-02-19 14:13:57 +0200
commit6d459fc1a0f17014891732f8f10fc92044574011 (patch)
tree38c460be0c5d3bffe6b1021f6504da8dd762686a
parenta470fab8497376f01483bea55fea292181f08dd1 (diff)
downloadaur-6d459fc1a0f17014891732f8f10fc92044574011.tar.gz
add a launcher for the launcher launcher
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
-rw-r--r--wrapper.sh3
3 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc2bec00c309..737423e6b127 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Feb 19 11:58:39 UTC 2016
+# Fri Feb 19 12:13:54 UTC 2016
pkgbase = runescape-launcher-nxt
pkgdesc = RuneScape MMORPG – NXT client core
pkgver = 2.0.6
- pkgrel = 1
+ pkgrel = 2
arch = x86_64
license = custom
depends = gcc-libs
@@ -13,7 +13,9 @@ pkgbase = runescape-launcher-nxt
depends = sdl2
depends = webkitgtk2
source_x86_64 = http://content.runescape.com/a=946/downloads/ubuntu/pool/non-free/r/runescape-launcher/runescape-launcher_2.0.6_amd64.deb
+ source_x86_64 = wrapper.sh
sha256sums_x86_64 = b59ef54de67abd362b6f32ae3a32a170470c51d2912780b6ae76fb0982dbacf0
+ sha256sums_x86_64 = d20151c9111a77e753954638eb60f1b4ec0d2c86e173041dcd95bb7b309d5b12
pkgname = runescape-launcher-nxt
diff --git a/PKGBUILD b/PKGBUILD
index 18bae5ac4dd7..042cd850d176 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=runescape-launcher-nxt
pkgver=2.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="RuneScape MMORPG – NXT client core"
arch=(x86_64)
license=(custom)
@@ -15,8 +15,10 @@ depends=(
sdl2
webkitgtk2
)
-source_x86_64=("http://content.runescape.com/a=946/downloads/ubuntu/pool/non-free/r/runescape-launcher/runescape-launcher_${pkgver}_amd64.deb")
-sha256sums_x86_64=('b59ef54de67abd362b6f32ae3a32a170470c51d2912780b6ae76fb0982dbacf0')
+source_x86_64=("http://content.runescape.com/a=946/downloads/ubuntu/pool/non-free/r/runescape-launcher/runescape-launcher_${pkgver}_amd64.deb"
+ "wrapper.sh")
+sha256sums_x86_64=('b59ef54de67abd362b6f32ae3a32a170470c51d2912780b6ae76fb0982dbacf0'
+ 'd20151c9111a77e753954638eb60f1b4ec0d2c86e173041dcd95bb7b309d5b12')
prepare() {
bsdtar xf control.tar.gz
@@ -25,8 +27,9 @@ prepare() {
package() {
cp -a usr "$pkgdir"
- sed -i '1aexport LD_PRELOAD="/usr/lib/libcurl.so.3"' "$pkgdir"/usr/bin/runescape-launcher
+ mv "$pkgdir"/usr/bin/runescape-launcher{,.real}
+ install -Dm0755 wrapper.sh "$pkgdir"/usr/bin/runescape-launcher
install -Dm0644 copyright "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-# vim: ft=sh:ts=4:sw=4:et
+# vim: ft=sh:ts=4:sw=4:et:nowrap
diff --git a/wrapper.sh b/wrapper.sh
new file mode 100644
index 000000000000..37c605415687
--- /dev/null
+++ b/wrapper.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+export LD_PRELOAD="/usr/lib/libcurl.so.3"
+exec /usr/bin/runescape-launcher.real "$@"