summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMantas Mikulėnas2019-11-13 08:39:44 +0200
committerMantas Mikulėnas2019-11-13 08:41:41 +0200
commitedab110d67b53de2370d29dbe1a05710fdece126 (patch)
treed486690dbce243c83a687a756dc45be2810fce86
parent44b8fb598be522025700483d8bdf0e080745f420 (diff)
downloadaur-edab110d67b53de2370d29dbe1a05710fdece126.tar.gz
enable CAP_SETFCAP
> JagexDark commented on 2019-11-11 14:32 > > Just a heads up that we have updated the launcher / apt repo to 2.2.5, > incorporating various fixes > https://secure.runescape.com/m=news/news-post-linux-client-improvements. > Most relevant change is the new set of dependencies, which should > hopefully be more version-stable going forward. > > Also of note is the new postinst script that grants CAP_SETFCAP on the > launcher binary - this is used ONLY to grant the permission to adjust > thread priorities to the client binary, which allows the audio threads > to be high priority, fixing a long-standing linux audio issue. If there > is a nicer way you can come up with to grant CAP_SYS_NICE to the client > binary then please do so instead.
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
-rw-r--r--install.sh17
3 files changed, 21 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04e06da2aab4..ccc83c844236 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = runescape-launcher
pkgdesc = RuneScape Game Client (NXT)
pkgver = 2.2.5
- pkgrel = 1
+ pkgrel = 2
url = https://www.runescape.com/
+ install = install.sh
arch = x86_64
license = custom
makedepends = gcc
diff --git a/PKGBUILD b/PKGBUILD
index f10b92782b66..2a9a2bf3fc46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=runescape-launcher
pkgver=2.2.5
-pkgrel=1
+pkgrel=2
pkgdesc="RuneScape Game Client (NXT)"
arch=(x86_64)
license=(custom)
@@ -31,6 +31,7 @@ sha256sums=('SKIP'
sha256sums_x86_64=('SKIP'
'SKIP')
validpgpkeys=("AAC9264309E4D717441DB9527373B12CE03BEB4B")
+install="install.sh"
# avoid caching in makepkg!
SRCDEST=$startdir
diff --git a/install.sh b/install.sh
new file mode 100644
index 000000000000..a8c31ceaaecd
--- /dev/null
+++ b/install.sh
@@ -0,0 +1,17 @@
+post_install() {
+ # For now, the launcher needs to set CAP_SYS_NICE on the downloaded game
+ # client (to make the audio issues go away), hence the CAP_SETFCAP.
+ #
+ # If the client eventually learns how to raise ambient capabilities, then
+ # just `setcap CAP_SYS_NICE` by itself will be enough. But we can't really
+ # achieve this at Arch side.
+
+ #setcap cap_sys_nice=eip usr/share/games/runescape-launcher/runescape
+ setcap cap_setfcap=eip usr/share/games/runescape-launcher/runescape
+}
+
+post_upgrade() {
+ post_install
+}
+
+# vim: ft=sh:ts=4:sw=4:et:nowrap