summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Schumacher2021-11-09 12:00:16 +0100
committerLeon Schumacher2021-11-09 12:00:16 +0100
commit687d91261170b683f6236cd6880858422e6a7be8 (patch)
tree3d95228bf661245bdf8c62cc7403c805bb4af38a
parent9f12f372d7ec2557edeae9711c4f8f376b185328 (diff)
downloadaur-687d91261170b683f6236cd6880858422e6a7be8.tar.gz
Update to version 8
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 847e8bf57b99..cf1344daf3e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = runit-conversion
pkgdesc = Convert your system to use runit instead of systemd
- pkgver = 7
- pkgrel = 2
+ pkgver = 8
+ pkgrel = 1
url = https://github.com/42LoCo42/runit-conversion
arch = any
license = GPL
depends = kisslinux-init
depends = runit
optdepends = runit-services: many service definitions
- provides = systemd
- source = runit-conversion-7.tar.gz::https://github.com/42LoCo42/runit-conversion/archive/refs/tags/v7.tar.gz
+ provides = systemd-sysvcompat
+ conflicts = systemd-sysvcompat
+ source = runit-conversion-8.tar.gz::https://github.com/42LoCo42/runit-conversion/archive/refs/tags/v7.tar.gz
sha256sums = 67b0028399f340a60462bbda7192c1007d50973e0d56b0e7f48a4195175811b1
pkgname = runit-conversion
diff --git a/PKGBUILD b/PKGBUILD
index 1810f18f78cd..171c60ca5fcd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Leon Schumacher <leonsch@protonmail.com>
# vim: ft=sh:
pkgname=runit-conversion
-pkgver=7
-pkgrel=2
+pkgver=8
+pkgrel=1
pkgdesc="Convert your system to use runit instead of systemd"
arch=('any')
url="https://github.com/42LoCo42/runit-conversion"
license=('GPL')
depends=('kisslinux-init' 'runit')
optdepends=('runit-services: many service definitions')
-provides=('systemd')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v7.tar.gz")
-sha256sums=('67b0028399f340a60462bbda7192c1007d50973e0d56b0e7f48a4195175811b1')
+conflicts=('systemd-sysvcompat')
+provides=('systemd-sysvcompat')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v8.tar.gz")
+sha256sums=('92449e629751a8a9f1828b4c1c3676531f88bb16f8310bcb5b2b147e4defe83a')
package() {
cd "$pkgname-$pkgver"
- cp -a ./* "$pkgdir/"
+ cp -aP ./* "$pkgdir/"
}