summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2020-11-19 01:52:02 +0200
committerjonian2020-11-19 01:52:02 +0200
commit5411f4e55b21cd64f655b1c50e1c1608c1c91027 (patch)
tree315043ab8377850bf8867d89418f20167f33711b
downloadaur-5411f4e55b21cd64f655b1c50e1c1608c1c91027.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD22
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4d841a79867
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = runjs-bin
+ pkgdesc = RunJS is an JavaScript playground that auto-evaluates your code as you type and outputs the results to a console pane
+ pkgver = 1.12.2
+ pkgrel = 1
+ url = https://github.com/lukehaas/RunJS
+ arch = x86_64
+ license = MIT
+ depends = nss
+ depends = libxss
+ depends = libnotify
+ depends = libsecret
+ depends = libappindicator-gtk3
+ depends = util-linux-libs
+ depends = xdg-utils
+ provides = runjs
+ conflicts = runjs
+ conflicts = runjs-git
+ source = runjs-bin-1.12.2.deb::https://github.com/lukehaas/RunJS/releases/download/v1.12.2/runjs_1.12.2_amd64.deb
+ sha256sums = bd7ac633f355dfcad718d984ad3dc4fa8919dc8b8cc73c2e8544916c57e88393
+
+pkgname = runjs-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ec12fbcbb66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=runjs-bin
+pkgver=1.12.2
+pkgrel=1
+pkgdesc="RunJS is an JavaScript playground that auto-evaluates your code as you type and outputs the results to a console pane"
+arch=("x86_64")
+url="https://github.com/lukehaas/RunJS"
+license=("MIT")
+depends=("nss" "libxss" "libnotify" "libsecret" "libappindicator-gtk3" "util-linux-libs" "xdg-utils")
+provides=("runjs")
+conflicts=("runjs" "runjs-git")
+source=("$pkgname-$pkgver.deb::$url/releases/download/v1.12.2/runjs_${pkgver}_amd64.deb")
+sha256sums=("bd7ac633f355dfcad718d984ad3dc4fa8919dc8b8cc73c2e8544916c57e88393")
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package() {
+ mv opt "$pkgdir"
+ mv usr "$pkgdir"
+}