summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonian2022-06-18 13:28:24 +0300
committerjonian2022-06-18 13:28:24 +0300
commit88e87225f7004e2d06289b8fe92a3c91f6003108 (patch)
tree2d45957b7b2a44c71c9922b8005f7ce68f99b3eb
parentfc27e4cb77b6eadb422242ae6a6626333995509b (diff)
downloadaur-88e87225f7004e2d06289b8fe92a3c91f6003108.tar.gz
add support for arm64
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06a73bcd385c..7925fc92418d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = runjs-bin
pkgdesc = RunJS is an JavaScript playground that auto-evaluates your code as you type and outputs the results to a console pane
pkgver = 2.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/lukehaas/RunJS
arch = x86_64
+ arch = aarch64
license = Commercial
depends = nss
depends = libxss
@@ -15,7 +16,9 @@ pkgbase = runjs-bin
provides = runjs
conflicts = runjs
conflicts = runjs-git
- source = runjs-bin-2.4.1.deb::https://github.com/lukehaas/RunJS/releases/download/v2.4.1/runjs_2.4.1_amd64.deb
- sha256sums = 1c301ea40f159731df2d64e7fb4f7671d2f6433efcfc6859ae1f4c1537c66f45
+ source_x86_64 = runjs-bin-2.4.1.deb::https://github.com/lukehaas/RunJS/releases/download/v2.4.1/runjs_2.4.1_amd64.deb
+ sha256sums_x86_64 = 1c301ea40f159731df2d64e7fb4f7671d2f6433efcfc6859ae1f4c1537c66f45
+ source_aarch64 = runjs-bin-2.4.1.deb::https://github.com/lukehaas/RunJS/releases/download/v2.4.1/runjs_2.4.1_arm64.deb
+ sha256sums_aarch64 = 97e987daa95363d19012082974e346f3b5a89a71be14520b5d05fc70d06c2d67
pkgname = runjs-bin
diff --git a/PKGBUILD b/PKGBUILD
index d763d1d2a5c8..6dddbc78a0e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=runjs-bin
pkgver=2.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="RunJS is an JavaScript playground that auto-evaluates your code as you type and outputs the results to a console pane"
-arch=("x86_64")
+arch=("x86_64" "aarch64")
url="https://github.com/lukehaas/RunJS"
license=("Commercial")
depends=("nss" "libxss" "libnotify" "libsecret" "libappindicator-gtk3" "util-linux-libs" "xdg-utils")
provides=("runjs")
conflicts=("runjs" "runjs-git")
-source=("$pkgname-$pkgver.deb::$url/releases/download/v${pkgver}/runjs_${pkgver}_amd64.deb")
-sha256sums=('1c301ea40f159731df2d64e7fb4f7671d2f6433efcfc6859ae1f4c1537c66f45')
+source_x86_64=("$pkgname-$pkgver.deb::$url/releases/download/v${pkgver}/runjs_${pkgver}_amd64.deb")
+source_aarch64=("$pkgname-$pkgver.deb::$url/releases/download/v${pkgver}/runjs_${pkgver}_arm64.deb")
+sha256sums_x86_64=('1c301ea40f159731df2d64e7fb4f7671d2f6433efcfc6859ae1f4c1537c66f45')
+sha256sums_aarch64=('97e987daa95363d19012082974e346f3b5a89a71be14520b5d05fc70d06c2d67')
prepare() {
bsdtar xf data.tar.xz