summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordustball2015-08-08 14:51:40 +0200
committerdustball2015-08-08 14:51:40 +0200
commitc7596b990ef30bd64325abedd6e2248d2bab5183 (patch)
treeb6946e682e69be3fa20494418bcfde3233f07861
downloadaur-c7596b990ef30bd64325abedd6e2248d2bab5183.tar.gz
Init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD56
2 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..45976a6215ce
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = runner2
+ pkgdesc = BIT.TRIP Presents... Runner2: Future Legend of Rhythm Alien
+ pkgver = 1.0
+ pkgrel = 3
+ url = http://www.runner2.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl
+ depends = libgl
+ depends = zlib
+ source = hib://runner2__1388171186.tar.gz
+
+pkgname = runner2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f356f0f7dfd8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Niluge_KiWi <kiwiiii@gmail.com>
+
+pkgname=runner2
+pkgver=1.0
+_hibver=1388171186
+pkgrel=3
+pkgdesc="BIT.TRIP Presents... Runner2: Future Legend of Rhythm Alien"
+url="http://www.runner2.com/"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('sdl' 'libgl' 'zlib')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+case $CARCH in
+ i686)
+ _archive_arch='i386'
+ _archive_md5='ea105bdcd486879fb99889b87e90eed5' ;;
+ x86_64)
+ _archive_arch='amd64'
+ _archive_md5='2f7ccdb675a63a5fc152514682e97480' ;;
+esac
+_archive="runner2_${_archive_arch}_${_hibver}.tar.gz"
+
+source=("hib://${_archive}")
+md5sums=("${_archive_md5}")
+
+# don't compress the generated package as it's just a transient package
+PKGEXT='.pkg.tar'
+
+package()
+{
+ cd "${pkgname}-1.0/"
+
+ # Install game files
+ mkdir -p "${pkgdir}/opt/${pkgname}/"
+ mv "${pkgname}"/* "${pkgdir}/opt/${pkgname}/"
+
+ # Install launcher script
+ echo -e "#!/bin/sh\ncd /opt/${pkgname} && ./${pkgname}" \
+ > "launcher.sh"
+ install -Dm755 "launcher.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Install desktop entry
+ # patch the included desktop entry paths
+ sed -i 's|/usr/local/bin|/usr/bin|' "${pkgname}.desktop"
+ sed -i 's|/usr/local/share/gaijin_games|/opt|' "${pkgname}.desktop"
+ install -Dm644 "${PWD}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Install documentation
+ mkdir -p "${pkgdir}/usr/share/doc/${pkgname}"
+ mv "README"* "${pkgdir}/usr/share/doc/${pkgname}"
+
+ # cleanup
+ rm -rf "${pkgdir}/opt/tmp/"
+}