summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2018-01-07 14:32:07 +0100
committerPiotr Rogoża2018-01-07 14:32:07 +0100
commit80afe4e0742b5f619792b38fa9a2dce0ff6c0a22 (patch)
tree682fcfe5d7c7648d34ff3b12a3332c3d22b8fc77
downloadaur-80afe4e0742b5f619792b38fa9a2dce0ff6c0a22.tar.gz
Release a new package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD25
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1c540ed3fac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Jan 7 13:31:44 UTC 2018
+pkgbase = runtastic
+ pkgdesc = Command line tool to archive all your Runtastic activities
+ pkgver = 2.1.1
+ pkgrel = 1
+ url = https://github.com/Metalnem/runtastic
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = glibc
+ source = runtastic-2.1.1.tar.gz::https://github.com/Metalnem/runtastic/archive/v2.1.1.tar.gz
+ sha256sums = 3acb230ddad16802da0f5688a231784e2f86bc4c81c20d974eef964feee8ebc4
+
+pkgname = runtastic
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d00370de2e70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
+
+pkgname=runtastic
+pkgver=2.1.1
+pkgrel=1
+pkgdesc='Command line tool to archive all your Runtastic activities'
+arch=('i686' 'x86_64')
+url='https://github.com/Metalnem/runtastic'
+license=('MIT')
+depends=(glibc)
+makedepends=()
+source=("$pkgname-$pkgver.tar.gz::https://github.com/Metalnem/runtastic/archive/v${pkgver}.tar.gz")
+sha256sums=('3acb230ddad16802da0f5688a231784e2f86bc4c81c20d974eef964feee8ebc4')
+_gourl=github.com/Metalnem/runtastic
+
+build(){
+ cd "$srcdir"/$pkgname-$pkgver
+ GOPATH="$srcdir" go get -fix -v -x ${_gourl}
+}
+package(){
+ cd "$srcdir"/$pkgname-$pkgver
+ install -Dm755 "$srcdir/bin/runtastic" "$pkgdir/usr/bin/runtastic"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+