summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAskhat2015-12-21 21:47:13 +0600
committerAskhat2015-12-21 21:47:13 +0600
commit4cb1907ff523e3fe8d9e47fa7e5da84374094d57 (patch)
tree28b9838fb250f84b9a7ec9d991b7d94f0865038f
downloadaur-runzip.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7510fab84096
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Dec 21 15:46:20 UTC 2015
+pkgbase = runzip
+ pkgdesc = Convert filenames inside ZIP archives from autodetected older Russian encodings (koi8-r, koi8-u, cp866, windows-1251) to UTF-8
+ pkgver = 1.4
+ pkgrel = 1
+ url = https://github.com/vlm/zip-fix-filename-encoding/releases
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = zlib
+ source = https://github.com/vlm/zip-fix-filename-encoding/releases/download/v1.4/runzip-1.4.tar.gz
+ source = https://raw.githubusercontent.com/vlm/zip-fix-filename-encoding/master/LICENSE
+ sha256sums = e3efc83744067815bb920df6aa706b87b2985dd6eccc9f76a9d9f668ddc8d44d
+ sha256sums = 97a5e3ed2793a375b322a690be0cae61a76f013c5b28124e71ee25694ce3f25c
+
+pkgname = runzip
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1238382bfddb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: <sirocco@ngs.ru>
+pkgname=runzip
+pkgver=1.4
+pkgrel=1
+pkgdesc="Convert filenames inside ZIP archives from autodetected older Russian encodings (koi8-r, koi8-u, cp866, windows-1251) to UTF-8"
+arch=(i686 x86_64)
+url="https://github.com/vlm/zip-fix-filename-encoding/releases"
+license=(custom)
+depends=('zlib')
+source=("https://github.com/vlm/zip-fix-filename-encoding/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/vlm/zip-fix-filename-encoding/master/LICENSE")
+sha256sums=('e3efc83744067815bb920df6aa706b87b2985dd6eccc9f76a9d9f668ddc8d44d'
+ '97a5e3ed2793a375b322a690be0cae61a76f013c5b28124e71ee25694ce3f25c')
+
+
+build() {
+ cd ${pkgname}-${pkgver}
+
+ ./configure
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+
+ #make install DESTDIR="${pkgdir}"/usr/bin/
+ install -Dm755 src/"${pkgname}" "${pkgdir}"/usr/bin/"${pkgname}"
+ install -Dm644 ../LICENSE $pkgdir/usr/share/licenses/"${pkgname}"/LICENSE
+}