summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112017-08-08 22:38:14 +0200
committerjose17112017-08-08 22:38:14 +0200
commitbfd6c3131c2b822d933774a8aadb99fa62def8bc (patch)
tree78af8a6b27e3b73bead379a5458e54db9f7fd408
downloadaur-bfd6c3131c2b822d933774a8aadb99fa62def8bc.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8ddc55fb87e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Aug 8 20:38:05 UTC 2017
+pkgbase = ruplicity-fuse
+ pkgdesc = Mount duplicity backups with userspace filesystem
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/mbrt/ruplicity-fuse
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL2
+ makedepends = rust
+ makedepends = cargo
+ depends = fuse2
+
+pkgname = ruplicity-fuse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8595fa777cfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Jose Riha <jose1711 gmail com>
+# Generated with cargo-pkgbuild
+pkgname=ruplicity-fuse
+pkgver=0.0.1
+pkgrel=1
+makedepends=('rust' 'cargo')
+depends=('fuse2')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url='https://github.com/mbrt/ruplicity-fuse'
+pkgdesc="Mount duplicity backups with userspace filesystem"
+license=('GPL2')
+
+package() {
+ cd $srcdir
+ cargo install --root="$pkgdir/usr" --git=https://github.com/mbrt/ruplicity-fuse
+ rm $pkgdir/usr/.crates.toml
+}