summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormurlakatamenka2020-01-14 23:33:04 +0300
committermurlakatamenka2020-01-14 23:33:04 +0300
commit76319798a67115d78ab2611b3f58411e2a74e749 (patch)
tree72934fbc1501d2ba6703fb1806c2821f8dc347b1
downloadaur-76319798a67115d78ab2611b3f58411e2a74e749.tar.gz
Initial commit (first GitHub release of Rust Analyzer)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d40d0f3aa6cc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rust-analyzer-bin
+ pkgdesc = An experimental Rust compiler front-end for IDEs. Binary build.
+ pkgver = 20200113
+ pkgrel = 1
+ url = https://github.com/rust-analyzer/rust-analyzer
+ arch = x86_64
+ license = MIT
+ license = Apache
+ provides = rust-analyzer
+ conflicts = rust-analyzer
+ conflicts = rust-analyzer-git
+ conflicts = rust-analyzer-vscode-git
+ source = ra_lsp_server::https://github.com/rust-analyzer/rust-analyzer/releases/download/2020-01-13/ra_lsp_server-linux
+ md5sums = 0be102a3e9afb84683257c6e32199879
+
+pkgname = rust-analyzer-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c2e6da68ee7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Sergey A. <murlakatamenka@disroot.org>
+
+pkgname=rust-analyzer-bin
+pkgver=20200113
+_pkgver='2020-01-13'
+pkgrel=1
+pkgdesc="An experimental Rust compiler front-end for IDEs. Binary build."
+arch=('x86_64')
+url="https://github.com/rust-analyzer/rust-analyzer"
+license=('MIT' 'Apache')
+provides=('rust-analyzer')
+conflicts=('rust-analyzer' 'rust-analyzer-git' 'rust-analyzer-vscode-git')
+source=("ra_lsp_server::$url/releases/download/$_pkgver/ra_lsp_server-linux")
+md5sums=('0be102a3e9afb84683257c6e32199879')
+
+pkgver() {
+ echo ${_pkgver//-}
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 755 "ra_lsp_server" -t "$pkgdir/usr/bin/"
+}