summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquininer2018-12-20 00:08:00 +0800
committerquininer2018-12-20 00:08:00 +0800
commitffcae204337c7224649f63724c6caac3acd3b258 (patch)
treea6b44ba2729df4921a2f1a53d7673b38c040841e
downloadaur-ffcae204337c7224649f63724c6caac3acd3b258.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ea48878c3b9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rust-analyzer-git
+ pkgdesc = An experimental Rust compiler front-end for IDEs
+ pkgver = 0.1.0.1249.g0e1c01c
+ pkgrel = 1
+ url = https://github.com/rust-analyzer/rust-analyzer
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cargo
+ provides = rust-analyzer
+ conflicts = rust-analyzer
+ source = rust-analyzer-git::git+https://github.com/rust-analyzer/rust-analyzer.git
+ sha256sums = SKIP
+
+pkgname = rust-analyzer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de8653eb458f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+pkgname=rust-analyzer-git
+pkgver=0.1.0.1249.g0e1c01c
+pkgrel=1
+pkgdesc="An experimental Rust compiler front-end for IDEs"
+arch=('x86_64' 'i686')
+url="https://github.com/rust-analyzer/rust-analyzer"
+license=('MIT')
+depends=()
+makedepends=('cargo')
+optdepends=()
+provides=('rust-analyzer')
+conflicts=('rust-analyzer')
+source=($pkgname::git+https://github.com/rust-analyzer/rust-analyzer.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ echo $(grep '^version =' crates/ra_lsp_server/Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git describe --always)
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/ra_lsp_server" "$pkgdir/usr/bin/ra_lsp_server"
+ install -D -m755 "$srcdir/$pkgname/target/release/ra_cli" "$pkgdir/usr/bin/ra_cli"
+}