summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCsonka Mihaly2019-07-15 19:16:42 +0200
committerCsonka Mihaly2019-07-15 19:16:42 +0200
commit3501de90952c74a386b0cde75c7bea964738fa1f (patch)
tree406c40cb9b06f1e634575fe7824d7e4014ded9ec
downloadaur-3501de90952c74a386b0cde75c7bea964738fa1f.tar.gz
Init commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..914fb7cab5b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rust-analyzer-vscode-git
+ pkgdesc = An experimental Rust compiler front-end for IDEs (VSCode installation).
+ pkgver = r4319.8de56ec4
+ pkgrel = 1
+ url = https://github.com/rust-analyzer/rust-analyzer/
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = npm
+ depends = rustup
+ depends = code
+ provides = rust-analyzer-vscode-git
+ conflicts = rust-analyzer-vscode-git
+ conflicts = rust-analyzer-git
+ source = rust-analyzer-vscode-git::git+https://github.com/rust-analyzer/rust-analyzer/
+ md5sums = SKIP
+
+pkgname = rust-analyzer-vscode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77aa72b33000
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Kibouo <csonka.mihaly@hotmail.com>
+pkgname=rust-analyzer-vscode-git
+pkgver=r4319.8de56ec4
+pkgrel=1
+pkgdesc='An experimental Rust compiler front-end for IDEs (VSCode installation).'
+arch=('any')
+url='https://github.com/rust-analyzer/rust-analyzer/'
+license=('MIT')
+depends=('rustup' 'code')
+makedepends=('git' 'npm')
+provides=("${pkgname}")
+conflicts=("${pkgname}" 'rust-analyzer-git')
+source=("${pkgname}::git+${url}")
+md5sums=('SKIP')
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ cargo build --release
+
+ cd ./editors/code
+ npm install
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "$srcdir/$pkgname/target/release/ra_lsp_server" "$pkgdir/usr/bin/ra_lsp_server"
+ install -D -m755 "$srcdir/$pkgname/target/release/ra_cli" "$pkgdir/usr/bin/ra_cli"
+
+ cd ./editors/code
+ ./node_modules/vsce/out/vsce package
+ code --install-extension ./ra-lsp-0.0.1.vsix
+} \ No newline at end of file