summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTatsuyuki Ishi2017-04-17 16:06:45 +0900
committerTatsuyuki Ishi2017-04-17 16:06:45 +0900
commit12bcabedd0608ef65814d497d9de91c063c858e4 (patch)
treed8ddf0648115be85c22d2f09d1d3b6caae4e27d6
downloadaur-12bcabedd0608ef65814d497d9de91c063c858e4.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD38
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32826ec42016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Mon Apr 17 07:05:16 UTC 2017
+pkgbase = rust-clippy-git
+ pkgdesc = A collection of lints to catch common mistakes and improve your Rust code
+ pkgver = 0.0.124.r2428.6f2fe144
+ pkgrel = 1
+ url = https://github.com/Manishearth/rust-clippy
+ arch = x86_64
+ arch = i686
+ license = MPL
+ makedepends = cargo
+ depends = curl
+ depends = rust-git
+ provides = rust-clippy
+ conflicts = rust-clippy
+ source = git+https://github.com/Manishearth/rust-clippy.git
+ sha512sums = SKIP
+
+pkgname = rust-clippy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7063a064d49e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+pkgname=rust-clippy-git
+_gitname=rust-clippy
+pkgver=0.0.124.r2428.6f2fe144
+pkgrel=1
+pkgdesc='A collection of lints to catch common mistakes and improve your Rust code'
+url='https://github.com/Manishearth/rust-clippy'
+arch=('x86_64' 'i686')
+license=('MPL')
+depends=('curl' 'rust-git')
+provides=('rust-clippy')
+conflicts=('rust-clippy')
+makedepends=('cargo')
+source=("git+https://github.com/Manishearth/rust-clippy.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ echo $(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+prepare() {
+ cd "$_gitname"
+}
+
+build() {
+ cd "$_gitname"
+
+ cargo build --release
+}
+
+package() {
+ cd "$_gitname"
+
+ cargo install --root "$pkgdir/usr"
+ rm "$pkgdir/usr/.crates.toml"
+}
+
+# vim:set ts=2 sw=2 et: