summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-12-28 13:44:23 +0330
committerMohammadreza Abdollahzadeh2022-12-28 13:44:23 +0330
commit8c6c3c719421f80d57fd5bc66d126d753ec33a1d (patch)
tree9e0ba2df474c005f7c249bef1b54e6c0af8059e2
downloadaur-8c6c3c719421f80d57fd5bc66d126d753ec33a1d.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3ded757a94a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = rust-docs
+ pkgdesc = Rust documentations.
+ pkgver = 1.66.0
+ pkgrel = 1
+ url = https://www.rust-lang.org/
+ arch = x86_64
+ license = Apache
+ license = MIT
+ options = docs
+ source = https://static.rust-lang.org/dist/rust-docs-1.66.0-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = 7255b6cd4104d98e75c27b16a7b6c07bc4bf1524d4d497f36040617373e5a783
+
+pkgname = rust-docs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..831f16564fb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+pkgname=rust-docs
+pkgver=1.66.0
+pkgrel=1
+pkgdesc="Rust documentations."
+arch=('x86_64')
+url="https://www.rust-lang.org/"
+license=('Apache' 'MIT')
+options=('docs')
+source=("https://static.rust-lang.org/dist/rust-docs-${pkgver}-${CARCH}-unknown-linux-gnu.tar.gz")
+sha256sums=('7255b6cd4104d98e75c27b16a7b6c07bc4bf1524d4d497f36040617373e5a783')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}-${CARCH}-unknown-linux-gnu/${pkgname}/share/doc/"
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname%-docs}"
+ cp -r rust/html "${pkgdir}/usr/share/doc/${pkgname%-docs}/"
+}
+# vim:set ts=4 sw=4 et: