summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Beste2017-04-24 12:59:20 -0500
committerDan Beste2017-04-24 12:59:20 -0500
commit31c622d8367016d4aaaff076e59500de72b93268 (patch)
tree1a4ba150a3ca268120a00b5914fb88edca8a1d27
parentdfaef9de6d8022efa02e257b6746014c64969dff (diff)
downloadaur-31c622d8367016d4aaaff076e59500de72b93268.tar.gz
PKGBUILD cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD67
2 files changed, 25 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37fd6b898ac4..9e62feb34b2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rust-doom-git
pkgdesc = A little Doom 1 & 2 Renderer written in Rust.
- pkgver = r323.40f22ca
+ pkgver = r325.5b2a843
pkgrel = 1
url = https://github.com/cristicbz/rust-doom
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 63d53c3b4d23..272b42e2d07a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,62 +3,43 @@
# TODO
# 1. Firejail profile + script
-pkgname=rust-doom-git
-reponame=rust-doom
-execname=rs_doom
-pkgver=r323.40f22ca
+pkgname='rust-doom-git'
+_reponame='rust-doom'
+_execname='rs_doom'
+pkgver=r325.5b2a843
pkgrel=1
pkgdesc='A little Doom 1 & 2 Renderer written in Rust.'
-arch=(
- 'i686'
- 'x86_64'
-)
+arch=('i686' 'x86_64')
url='https://github.com/cristicbz/rust-doom'
-license=(
- 'Apache'
-)
-depends_x86_64=(
- 'sdl2'
- 'sdl2_ttf'
-)
-depends_i686=(
- 'lib32-sdl2'
- 'lib32-sdl2_ttf'
-)
-makedepends=(
- 'cargo'
- 'git'
- 'rust'
-)
-provides=(
- "${execname}"
-)
-conflicts=(
- "${execname}"
-)
-source=(
- 'git+https://github.com/cristicbz/rust-doom.git'
-)
-sha256sums=(
- 'SKIP'
-)
+license=('Apache')
+depends_x86_64=('sdl2' 'sdl2_ttf')
+depends_i686=('lib32-sdl2' 'lib32-sdl2_ttf')
+makedepends=('cargo' 'git' 'rust')
+provides=("${_reponame}")
+conflicts=("${_reponame}")
+source=('git+https://github.com/cristicbz/rust-doom.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${reponame}" || exit 1
+ cd "${_reponame}"
printf "r%s.%s" \
"$(git rev-list --count HEAD)" \
"$(git rev-parse --short HEAD)"
}
build() {
- cd "${srcdir}/${reponame}" || exit 1
+ cd "${_reponame}"
cargo build --release
}
package() {
- cd "${srcdir}/${reponame}" || exit 1
- install -m755 \
- -D "target/release/${execname}" "${pkgdir}/usr/bin/${execname}"
- install -m644 \
- -D "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd "${_reponame}"
+
+ install -Dm 755 \
+ "target/release/${_execname}" \
+ "${pkgdir}/usr/bin/${_reponame}"
+
+ install -Dm 644 \
+ LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}