summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2017-03-12 13:59:56 +0100
committerspider-mario2017-03-12 14:00:10 +0100
commite577007db69ff3cdb0aaf525c7665d3afb6d2832 (patch)
tree4bdf240628f7928a3094c2dcc89d539bbdf27d35
parentc307b254189fe8c6d1f2fa17118ec83571bf0862 (diff)
downloadaur-e577007db69ff3cdb0aaf525c7665d3afb6d2832.tar.gz
Add a few new submodules
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3947f852a7fb..3f35c219d3b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,10 +17,13 @@ pkgbase = rust-git
makedepends = llvm
makedepends = jemalloc
source = git+https://github.com/rust-lang/rust.git
+ source = git+https://github.com/rust-lang/cargo.git
source = git+https://github.com/rust-lang/compiler-rt.git
source = git+https://github.com/rust-lang/libc.git
source = git+https://github.com/rust-lang/hoedown.git
source = git+https://github.com/rust-lang/rust-installer.git
+ source = git+https://github.com/rust-lang-nursery/nomicon.git
+ source = git+https://github.com/rust-lang-nursery/reference.git
source = git+https://github.com/rust-lang/rust.vim.git
source = git+https://github.com/rust-lang/rust-mode.git
source = git+https://github.com/rust-lang/zsh-config.git
@@ -32,6 +35,9 @@ pkgbase = rust-git
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = rust-git
install = rust.install
diff --git a/PKGBUILD b/PKGBUILD
index 64a4d21e2603..1289bf8c41d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,15 +11,19 @@ url="http://www.rust-lang.org/"
license=('MIT' 'Apache')
makedepends=('git' 'libffi' 'python2' 'curl' 'llvm' 'jemalloc')
source=("git+https://github.com/rust-lang/rust.git"
+ "git+https://github.com/rust-lang/cargo.git"
"git+https://github.com/rust-lang/compiler-rt.git"
"git+https://github.com/rust-lang/libc.git"
"git+https://github.com/rust-lang/hoedown.git"
"git+https://github.com/rust-lang/rust-installer.git"
+ "git+https://github.com/rust-lang-nursery/nomicon.git"
+ "git+https://github.com/rust-lang-nursery/reference.git"
+
"git+https://github.com/rust-lang/rust.vim.git"
"git+https://github.com/rust-lang/rust-mode.git"
"git+https://github.com/rust-lang/zsh-config.git")
-_noclone=(compiler-rt libc hoedown rust-installer)
+_noclone=(cargo compiler-rt libc hoedown rust-installer nomicon reference)
sha512sums=('SKIP'
'SKIP'
'SKIP'
@@ -27,6 +31,9 @@ sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {