summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAston2020-06-25 15:49:14 +0300
committerAston2020-06-25 15:49:14 +0300
commitf328af0ea5186983b35d0f068445f76e5786f723 (patch)
tree7a4bf0c56656babab1da0e8a7c8d076f7584c50b
parent9b007c7b72868d4a88416b35cf95427f1cb522ce (diff)
downloadaur-f328af0ea5186983b35d0f068445f76e5786f723.tar.gz
rust-keylock-ui v0.12.0
* Passphrases generation using Diceware. * Passwords health check against pwned passwords list, leveraging the k-anonimity API. Changelist Check passwords health functionality. Diceware: Generate passphrases. Applying password entries filter with a button (or hitting enter) in Desktop and Android. Upgraded third party libraries. Bugfixing
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df9d24bde348..84e90e774cb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rust-keylock-ui
pkgdesc = Password manager with goals to be Secure, Simple to use, Portable and Extensible
- pkgver = 0.8.2
+ pkgver = 0.12.0
pkgrel = 1
url = https://rust-keylock.github.io/
arch = x86_64
@@ -11,11 +11,11 @@ pkgbase = rust-keylock-ui
makedepends = libxcb
makedepends = python
depends = openssl
- depends = java-runtime>=8
+ depends = java-runtime>=11
depends = libxfixes
depends = libxrender
- source = https://github.com/rust-keylock/rust-keylock-ui/archive/v0.8.2.tar.gz
- sha512sums = e468d6f31785523528f0545e067699af0b4352a58490bb4e176eda477b6e8530420b598ccc15fb56909c50dffead218cca257100f1d0f9f5789ad57a7c7bde20
+ source = https://github.com/rust-keylock/rust-keylock-ui/archive/v0.12.0.tar.gz
+ sha512sums = c02bd39991b3ec9be76d7bad6d8adcf49ec21b3a550c495bfe5cacfb1068b4d4d735e043d3a3892e97be20bdfdaec8e6a6dcae7e6a09e52353e6d546dda7558a
pkgname = rust-keylock-ui
diff --git a/PKGBUILD b/PKGBUILD
index e7be6fe4b710..49164dc14932 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Aston <astonbitecode at gmail dot com>
pkgname="rust-keylock-ui"
-pkgver="0.8.2"
+pkgver="0.12.0"
pkgrel=1
epoch=
pkgdesc="Password manager with goals to be Secure, Simple to use, Portable and Extensible"
@@ -9,7 +9,7 @@ arch=("x86_64")
url="https://rust-keylock.github.io/"
license=("GPL")
groups=()
-depends=("openssl" "java-runtime>=8" "libxfixes" "libxrender")
+depends=("openssl" "java-runtime>=11" "libxfixes" "libxrender")
makedepends=("gendesk" "rust" "maven" "libxcb" "python")
checkdepends=()
optdepends=()
@@ -22,7 +22,7 @@ install=
changelog=
source=("https://github.com/rust-keylock/$pkgname/archive/v$pkgver.tar.gz")
noextract=()
-sha512sums=("e468d6f31785523528f0545e067699af0b4352a58490bb4e176eda477b6e8530420b598ccc15fb56909c50dffead218cca257100f1d0f9f5789ad57a7c7bde20")
+sha512sums=("c02bd39991b3ec9be76d7bad6d8adcf49ec21b3a550c495bfe5cacfb1068b4d4d735e043d3a3892e97be20bdfdaec8e6a6dcae7e6a09e52353e6d546dda7558a")
validpgpkeys=()
prepare() {
@@ -31,7 +31,7 @@ prepare() {
build() {
cd $srcdir/$pkgname-$pkgver
- mvn install -f scala/pom.xml
+ mvn install -f java/pom.xml
cargo build --release --manifest-path=rust/Cargo.toml
}
@@ -44,9 +44,8 @@ package() {
cp $srcdir/$pkgname-$pkgver/rust/target/release/rust-keylock-ui $pkgdir/opt/$pkgname/
cp $srcdir/$pkgname-$pkgver/rust/target/release/deps/libj4rs-*.so $pkgdir/opt/$pkgname/deps/
cp -R $srcdir/$pkgname-$pkgver/rust/target/release/jassets $pkgdir/opt/$pkgname/
- cp -R $srcdir/$pkgname-$pkgver/rust/target/release/scalaassets $pkgdir/opt/$pkgname/
-
+
ln -s /opt/$pkgname/rust-keylock-ui $pkgdir/usr/bin/rust-keylock-ui
install -Dm644 "$srcdir/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm644 "$srcdir/$pkgname-$pkgver/scala/src/main/resources/images/rkl.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/java/src/main/resources/images/rkl.png" "$pkgdir/usr/share/pixmaps/$pkgname.png"
}