summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Husmann2016-11-10 06:12:55 +0100
committerStefan Husmann2016-11-10 06:12:55 +0100
commit039d3166909fe76735a837e33bd9aebb0b641e22 (patch)
tree2c5b2a95d026733a5656c648c53d81cfe90f7f66
parent4c10cffa67af84f398b2b03344a932a32c574e36 (diff)
downloadaur-039d3166909fe76735a837e33bd9aebb0b641e22.tar.gz
add patch for building docs
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD14
-rw-r--r--docs.patch13
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11ce0dfd2472..86988bd75791 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Thu Nov 10 05:12:13 UTC 2016
pkgbase = rust-nightly
pkgdesc = A safe, concurrent, practical language
- pkgver = 1.13.0_2016.09.13
- pkgrel = 3
+ pkgver = 1.14.0_2016.11.09
+ pkgrel = 2
url = http://www.rust-lang.org/
arch = i686
arch = x86_64
@@ -22,8 +24,10 @@ pkgbase = rust-nightly
options = staticlibs
options = !strip
options = !emptydirs
- source = https://static.rust-lang.org/dist/2016-09-13/rustc-nightly-src.tar.gz
- sha256sums = 55a217902af13af83d981794536a680894bd44e5715e4b5133542d67a96c5590
+ source = http://static.rust-lang.org/dist/rustc-nightly-src.tar.gz
+ source = docs.patch
+ sha256sums = b73f77ec274bc1ade6badc5b4fab7076c10cf122f420f89eeeaa5548f63f4feb
+ sha256sums = f7e17374bf6bb5699f75d7792a7ece582144df79599956bf16df89e0ee0b41d5
pkgname = rust-nightly
depends = shared-mime-info
diff --git a/PKGBUILD b/PKGBUILD
index 19ae3a3010fb..734f610cea94 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,26 @@
pkgbase=rust-nightly
pkgname=('rust-nightly' 'rust-nightly-doc')
-pkgver=1.13.0_2016.09.13
-pkgrel=3
+pkgver=1.14.0_2016.11.09
+pkgrel=2
arch=('i686' 'x86_64')
pkgdesc='A safe, concurrent, practical language'
url='http://www.rust-lang.org/'
license=('MIT' 'Apache')
depends=('shared-mime-info')
makedepends=('libffi' 'perl' 'python2' 'curl' 'llvm' 'clang' 'haskell-pandoc' 'emacs')
-source=("https://static.rust-lang.org/dist/2016-09-13/rustc-nightly-src.tar.gz")
-sha256sums=('55a217902af13af83d981794536a680894bd44e5715e4b5133542d67a96c5590')
+source=("http://static.rust-lang.org/dist/rustc-nightly-src.tar.gz" docs.patch)
+sha256sums=('b73f77ec274bc1ade6badc5b4fab7076c10cf122f420f89eeeaa5548f63f4feb'
+ 'f7e17374bf6bb5699f75d7792a7ece582144df79599956bf16df89e0ee0b41d5')
options=('!makeflags' 'staticlibs' '!strip' '!emptydirs')
conflicts=('rust')
provides=('rust')
+prepare() {
+ cd rustc-nightly
+ patch -Np1 < "$srcdir"/docs.patch
+}
+
build() {
cd rustc-nightly
./configure --prefix=/usr --disable-rpath --enable-compiler-docs
diff --git a/docs.patch b/docs.patch
new file mode 100644
index 000000000000..fbe8921c7d2e
--- /dev/null
+++ b/docs.patch
@@ -0,0 +1,13 @@
+diff --git a/mk/crates.mk b/mk/crates.mk
+index c7abf27..f68fc2a 100644
+--- a/mk/crates.mk
++++ b/mk/crates.mk
+@@ -78,7 +78,6 @@ DEPS_panic_abort := libc alloc
+ DEPS_panic_unwind := libc alloc unwind
+ DEPS_unwind := libc
+
+-RUSTFLAGS_compiler_builtins := -lstatic=compiler-rt
+
+ # FIXME(stage0): change this to just `RUSTFLAGS_panic_abort := ...`
+ RUSTFLAGS1_panic_abort := -C panic=abort
+ \ No newline at end of file