summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikola Kotur2016-08-30 15:45:53 +0200
committerNikola Kotur2016-08-30 15:49:52 +0200
commitb369e3ee6734ccecf0f07ded9743d75a55989199 (patch)
tree342b20576859d84cdd4ca40edfdc9f5b4e67da13
downloadaur-b369e3ee6734ccecf0f07ded9743d75a55989199.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..867a4bbaf678
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rust-parallel-git
+ pkgdesc = Command-line CPU load balancer written in Rust
+ pkgver = 0.1.0.r7.g6861710
+ pkgrel = 1
+ url = https://github.com/mmstick/parallel
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = rust>=1.11.0
+ makedepends = cargo>=0.12.0
+ makedepends = git>=1
+ conflicts = parallel
+ source = parallel::git+https://github.com/mmstick/parallel.git#branch=master
+ md5sums = SKIP
+
+pkgname = rust-parallel-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..050817bdbf13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nikola Kotur <kotnick@gmail.com>
+pkgname=rust-parallel-git
+pkgver=0.1.0.r7.g6861710
+pkgrel=1
+pkgdesc="Command-line CPU load balancer written in Rust"
+arch=('i686'
+ 'x86_64')
+url="https://github.com/mmstick/parallel"
+license=('MIT')
+makedepends=(
+ 'rust>=1.11.0'
+ 'cargo>=0.12.0'
+ 'git>=1')
+conflicts=('parallel')
+source=('rust-parallel-git::git+https://github.com/mmstick/parallel.git#branch=master')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -d -m 755 "$pkgdir/usr/bin"
+ install -D -s -m 755 "target/release/parallel" "$pkgdir/usr/bin/parallel"
+}