summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2022-09-10 19:21:52 +0200
committerOrhun Parmaksız2022-09-10 19:21:52 +0200
commit697826f540117f12f22c6f50b2229609ef7cfcc7 (patch)
treedb83dfcb8768e8e26e2913f9e395f7237c67b43a
parentf50f329ecbf0c5ddebd3908d1050612a3850a121 (diff)
downloadaur-697826f540117f12f22c6f50b2229609ef7cfcc7.tar.gz
upgpkg: rust-racer-git 2.2.1.r4.ga457c23-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a6190f99bfbc..50e336125bfa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = rust-racer-git
pkgdesc = Code completion for Rust
- pkgver = 2.0.10.r12.gc7c819e
+ pkgver = 2.2.1.r4.ga457c23
pkgrel = 1
- url = https://github.com/phildawes/racer
+ url = https://github.com/racer-rust/racer
install = rust-racer-git.install
arch = i686
arch = x86_64
- license = custom:MIT
+ license = MIT
+ makedepends = rustup
makedepends = git
- depends = rust
depends = gcc-libs
- optdepends = rust-src
provides = rust-racer
conflicts = rust-racer
- replaces = racer-git
- source = git+https://github.com/phildawes/racer.git
+ source = git+https://github.com/racer-rust/racer.git
md5sums = SKIP
pkgname = rust-racer-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9f6b2e29939d..0fb754960142 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
# Contributor: Vlad M. <vlad@archlinux.net>
# Contributor: issue <issue at archlinux dot info>
-# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# Maintainer: Orhun Parmaksız <orhun@archlinux.org>
pkgname=rust-racer-git
_pkgname=racer
-pkgver=2.0.10.r12.gc7c819e
+pkgver=2.2.1.r4.ga457c23
pkgrel=1
pkgdesc="Code completion for Rust"
-url="https://github.com/phildawes/racer"
-depends=('rust' 'gcc-libs')
-optdepends=('rust-src')
-makedepends=('git' )
+url="https://github.com/racer-rust/racer"
+depends=('gcc-libs')
+makedepends=('rustup' 'git')
provides=('rust-racer')
conflicts=('rust-racer')
-replaces=('racer-git')
arch=('i686' 'x86_64')
-license=('custom:MIT')
+license=('MIT')
md5sums=('SKIP')
install=$pkgname.install
-source=("git+https://github.com/phildawes/$_pkgname.git")
+source=("git+https://github.com/racer-rust/$_pkgname.git")
pkgver() {
cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+
build() {
cd "$_pkgname"
- cargo build --release --verbose
+ rustup set profile minimal
+ rustup default nightly-2020-07-21
+ cargo build --release --locked
}
package() {