summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-01-10 12:18:26 +0100
committerDaniel Peukert2020-01-10 12:18:26 +0100
commitbb76d8568734ccfcf2e9af15f074c186fabc9b4e (patch)
treef7a776bb33b908a699b61bea43b37e40eaf11be0
downloadaur-bb76d8568734ccfcf2e9af15f074c186fabc9b4e.tar.gz
Added rust-rage
-rw-r--r--.SRCINFO17
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD26
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad6d945ae0e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rust-rage-bin
+ pkgdesc = Rust implementation of the age encryption tool - binary version
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/str4d/rage
+ arch = x86_64
+ license = Apache
+ license = MIT
+ depends = fuse2
+ provides = rust-rage
+ conflicts = rust-rage
+ source = rust-rage-bin-0.1.1-1.tar.gz::https://github.com/str4d/rage/releases/download/v0.1.1/rage-v0.1.1-x86_64-linux.tar.gz
+ source = rust-rage-bin-0.1.1-1-LICENSE-MIT::https://github.com/str4d/rage/raw/v0.1.1/LICENSE-MIT
+ sha256sums = 9203fb4f6a3b1312f9af900185f7059171f1117e1772bc1bf32643b5797a310a
+ sha256sums = fe56c030c2d8c3404a37fe711cebb27ebea13d0aacf7e3524db4198335ad8cd1
+
+pkgname = rust-rage-bin
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2124c0a62222
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+_pkgname='rage'
+pkgname="rust-$_pkgname-bin"
+pkgver='0.1.1'
+pkgrel='1'
+pkgdesc='Rust implementation of the age encryption tool - binary version'
+arch=('x86_64')
+url="https://github.com/str4d/$_pkgname"
+license=('Apache' 'MIT')
+depends=('fuse2')
+provides=("rust-$_pkgname")
+conflicts=("rust-$_pkgname")
+source=(
+ "$pkgname-$pkgver-$pkgrel.tar.gz::$url/releases/download/v$pkgver/rage-v$pkgver-x86_64-linux.tar.gz"
+ "$pkgname-$pkgver-$pkgrel-LICENSE-MIT::$url/raw/v$pkgver/LICENSE-MIT"
+)
+sha256sums=('9203fb4f6a3b1312f9af900185f7059171f1117e1772bc1bf32643b5797a310a'
+ 'fe56c030c2d8c3404a37fe711cebb27ebea13d0aacf7e3524db4198335ad8cd1')
+
+package() {
+ cd "$srcdir/$_pkgname"
+ for binary in "$_pkgname" "$_pkgname-keygen" "$_pkgname-mount"; do
+ install -Dm755 "$binary" "$pkgdir/usr/bin/$binary"
+ done
+ install -Dm644 "../$pkgname-$pkgver-$pkgrel-LICENSE-MIT" "$pkgdir/usr/share/licenses/$pkgname/LICENSE-MIT"
+}