summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-01-11 01:31:05 +0100
committerDaniel Peukert2020-01-11 01:31:05 +0100
commitda41b1c4c77e7fd3254b4996c325add707ed9a57 (patch)
treeb4a5ad2975c8c6e87eebc8ce2c8f846ee4d3b917
parentbb76d8568734ccfcf2e9af15f074c186fabc9b4e (diff)
downloadaur-da41b1c4c77e7fd3254b4996c325add707ed9a57.tar.gz
Updated rust-rage to 0.2.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ad6d945ae0e9..77684a488391 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,23 @@
pkgbase = rust-rage-bin
pkgdesc = Rust implementation of the age encryption tool - binary version
- pkgver = 0.1.1
+ pkgver = 0.2.0
pkgrel = 1
url = https://github.com/str4d/rage
arch = x86_64
+ arch = armv7h
+ arch = aarch64
license = Apache
license = MIT
depends = fuse2
provides = rust-rage
conflicts = rust-rage
- source = rust-rage-bin-0.1.1-1.tar.gz::https://github.com/str4d/rage/releases/download/v0.1.1/rage-v0.1.1-x86_64-linux.tar.gz
- source = rust-rage-bin-0.1.1-1-LICENSE-MIT::https://github.com/str4d/rage/raw/v0.1.1/LICENSE-MIT
- sha256sums = 9203fb4f6a3b1312f9af900185f7059171f1117e1772bc1bf32643b5797a310a
+ source = rust-rage-bin-0.2.0-1-LICENSE-MIT::https://github.com/str4d/rage/raw/v0.2.0/LICENSE-MIT
sha256sums = fe56c030c2d8c3404a37fe711cebb27ebea13d0aacf7e3524db4198335ad8cd1
+ source_x86_64 = rust-rage-bin-0.2.0-1-x86_64.tar.gz::https://github.com/str4d/rage/releases/download/v0.2.0/rage-v0.2.0-x86_64-linux.tar.gz
+ sha256sums_x86_64 = 238c67d4f489f510488d23bd60b0e900ecb0ed8c5ad62abf216f1c2846a823f4
+ source_armv7h = rust-rage-bin-0.2.0-1-armv7h.tar.gz::https://github.com/str4d/rage/releases/download/v0.2.0/rage-v0.2.0-armv7-linux.tar.gz
+ sha256sums_armv7h = 987b12e7482e4c5e5e3eed066fe3cd1a2c941aeb1307bf8ce611fb7cdea77239
+ source_aarch64 = rust-rage-bin-0.2.0-1-aarch64.tar.gz::https://github.com/str4d/rage/releases/download/v0.2.0/rage-v0.2.0-arm64-linux.tar.gz
+ sha256sums_aarch64 = 56aee676deaf7d319b2098bbed78af346b03fcec6c6437ee1a955fd79134f6f7
pkgname = rust-rage-bin
diff --git a/PKGBUILD b/PKGBUILD
index 2124c0a62222..39159f345607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
_pkgname='rage'
pkgname="rust-$_pkgname-bin"
-pkgver='0.1.1'
+pkgver='0.2.0'
pkgrel='1'
pkgdesc='Rust implementation of the age encryption tool - binary version'
-arch=('x86_64')
+arch=('x86_64' 'armv7h' 'aarch64')
url="https://github.com/str4d/$_pkgname"
license=('Apache' 'MIT')
depends=('fuse2')
provides=("rust-$_pkgname")
conflicts=("rust-$_pkgname")
-source=(
- "$pkgname-$pkgver-$pkgrel.tar.gz::$url/releases/download/v$pkgver/rage-v$pkgver-x86_64-linux.tar.gz"
- "$pkgname-$pkgver-$pkgrel-LICENSE-MIT::$url/raw/v$pkgver/LICENSE-MIT"
-)
-sha256sums=('9203fb4f6a3b1312f9af900185f7059171f1117e1772bc1bf32643b5797a310a'
- 'fe56c030c2d8c3404a37fe711cebb27ebea13d0aacf7e3524db4198335ad8cd1')
+_releaseurl="$url/releases/download/v$pkgver"
+source_x86_64=("$pkgname-$pkgver-$pkgrel-x86_64.tar.gz::$_releaseurl/rage-v$pkgver-x86_64-linux.tar.gz")
+source_armv7h=("$pkgname-$pkgver-$pkgrel-armv7h.tar.gz::$_releaseurl/rage-v$pkgver-armv7-linux.tar.gz")
+source_aarch64=("$pkgname-$pkgver-$pkgrel-aarch64.tar.gz::$_releaseurl/rage-v$pkgver-arm64-linux.tar.gz")
+source=("$pkgname-$pkgver-$pkgrel-LICENSE-MIT::$url/raw/v$pkgver/LICENSE-MIT")
+sha256sums=('fe56c030c2d8c3404a37fe711cebb27ebea13d0aacf7e3524db4198335ad8cd1')
+sha256sums_x86_64=('238c67d4f489f510488d23bd60b0e900ecb0ed8c5ad62abf216f1c2846a823f4')
+sha256sums_armv7h=('987b12e7482e4c5e5e3eed066fe3cd1a2c941aeb1307bf8ce611fb7cdea77239')
+sha256sums_aarch64=('56aee676deaf7d319b2098bbed78af346b03fcec6c6437ee1a955fd79134f6f7')
package() {
cd "$srcdir/$_pkgname"