summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWenxuan Zhang2020-10-30 16:21:31 +0800
committerWenxuan Zhang2020-10-30 16:21:31 +0800
commit51bda6cf4268e9772b279170cd74adbf04108177 (patch)
treec2386d9dbd1d6a93e53f12645627ab29b702d5a5
parent8efd8703509248644d3d5b8239be0d3b71f76faa (diff)
downloadaur-51bda6cf4268e9772b279170cd74adbf04108177.tar.gz
update package url
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile6
-rw-r--r--PKGBUILD8
-rw-r--r--PKGBUILD.tmpl6
4 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74340833ceb7..062456a6a8d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = rust-script
- pkgdesc = Run Rust files and expressions without any setup or compilation necessary.
+ pkgdesc = Run Rust files and expressions without any setup or compilation necessary
pkgver = 0.7.0
- pkgrel = 1
- url = https://github.com/fornwall/rust-script
+ pkgrel = 2
+ url = https://rust-script.org
arch = i686
arch = x86_64
license = MIT
diff --git a/Makefile b/Makefile
index 7b8f83596bd5..9c2435c55ee6 100644
--- a/Makefile
+++ b/Makefile
@@ -1,8 +1,9 @@
USER = fornwall
REPO = rust-script
-PKGDESC = Run Rust files and expressions without any setup or compilation necessary.
+PKGDESC = Run Rust files and expressions without any setup or compilation necessary
+PKGURL = https://rust-script.org
PKGVER = 0.7.0
-PKGREL = 1
+PKGREL = 2
MAINTAINER = $(shell git config user.name) <$(shell git config user.email)>
PKGNAME = $(REPO)
@@ -15,6 +16,7 @@ codegen:
@sed \
-e 's#{{USER}}#$(USER)#g' \
-e 's#{{REPO}}#$(REPO)#g' \
+ -e 's#{{PKGURL}}#$(PKGURL)#g' \
-e 's#{{MAINTAINER}}#$(MAINTAINER)#g' \
-e 's#{{PKGNAME}}#$(PKGNAME)#g' \
-e 's#{{BINNAME}}#$(BINNAME)#g' \
diff --git a/PKGBUILD b/PKGBUILD
index be813db70cfe..29d19fb4b33d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
_pkgname=rust-script
pkgname=rust-script
pkgver=0.7.0
-pkgrel=1
-pkgdesc="Run Rust files and expressions without any setup or compilation necessary."
+pkgrel=2
+pkgdesc='Run Rust files and expressions without any setup or compilation necessary'
arch=(i686 x86_64)
-url='https://github.com/fornwall/rust-script'
+url='https://rust-script.org'
license=('MIT' 'APACHE')
depends=()
makedepends=('rust>=1.47')
conflicts=("rust-script-git" "rust-script-bin")
provides=()
-source=("${url}/archive/v${pkgver}.tar.gz")
+source=("https://github.com/fornwall/rust-script/archive/v${pkgver}.tar.gz")
md5sums=('9889f3143125df5ae4a31afa2b901f50')
build() {
diff --git a/PKGBUILD.tmpl b/PKGBUILD.tmpl
index 7994407a6ae4..1d005fc1d47c 100644
--- a/PKGBUILD.tmpl
+++ b/PKGBUILD.tmpl
@@ -3,16 +3,16 @@ _pkgname={{BINNAME}}
pkgname={{PKGNAME}}
pkgver={{PKGVER}}
pkgrel={{PKGREL}}
-pkgdesc="{{PKGDESC}}"
+pkgdesc='{{PKGDESC}}'
arch=(i686 x86_64)
-url='https://github.com/{{USER}}/{{REPO}}'
+url='{{PKGURL}}'
license=('MIT' 'APACHE')
depends=()
makedepends=('rust>=1.47')
conflicts={{CONFLICTS}}
provides={{PROVIDES}}
-source=("${url}/archive/v${pkgver}.tar.gz")
+source=("https://github.com/{{USER}}/{{REPO}}/archive/v${pkgver}.tar.gz")
md5sums=('{{MD5SUM}}')
build() {