summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2021-06-27 13:16:42 +0800
committertaotieren2021-06-27 13:16:42 +0800
commit8dba003df969b3166512a14e186e55e531a4ba85 (patch)
treef29f926eed7ba2d096cca4906d17deb535168ba7
downloadaur-8dba003df969b3166512a14e186e55e531a4ba85.tar.gz
Update rustdesk-bin v1.1.6
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD30
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c55f93f91eb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = rustdesk-bin
+ pkgdesc = Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!
+ pkgver = 1.1.6
+ pkgrel = 1
+ url = https://github.com/rustdesk/rustdesk
+ arch = x86_64
+ license = GPLv3
+ makedepends = unzip
+ makedepends = zip
+ makedepends = pkg-config
+ makedepends = make
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = curl
+ makedepends = wget
+ makedepends = rust
+ makedepends = yasm
+ makedepends = nasm
+ makedepends = clang
+ depends = gtk3
+ depends = xdotool
+ depends = libxcb
+ depends = libxfixes
+ depends = alsa-lib
+ depends = pulseaudio
+ provides = rustdesk-bin
+ conflicts = rustdesk-bin
+ conflicts = rustdesk
+ conflicts = rustdesk-git
+ noextract = rustdesk-1.1.6-manjaro-arch.pkg.tar.zst
+ options = !strip
+ source = https://github.com/rustdesk/rustdesk/releases/download/1.1.6/rustdesk-1.1.6-manjaro-arch.pkg.tar.zst
+ sha256sums = dbfd6ea2e6994f5157f5794049796a06ea94d424c41121f30181e6ff48fbcaa3
+
+pkgname = rustdesk-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..37bb465dc2db
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*
+*.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b6a89ca37be9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: taotieren <admin@taotieren.com>
+
+pkgname=rustdesk-bin
+pkgver=1.1.6
+pkgrel=1
+pkgdesc="Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk! "
+arch=('x86_64')
+url="https://github.com/rustdesk/rustdesk"
+license=('GPLv3')
+provides=(${pkgname})
+conflicts=(${pkgname} ${pkgname%-bin} ${pkgname/bin/git} )
+#replaces=(${pkgname})
+depends=('gtk3' 'xdotool' 'libxcb' 'libxfixes' 'alsa-lib' 'pulseaudio')
+# 'libsciter-gtk-bin'
+makedepends=('unzip' 'zip' 'pkg-config' 'make' 'git' 'cmake' 'gcc' 'curl' 'wget' 'rust' 'yasm' 'nasm' 'clang')
+backup=()
+options=('!strip')
+#install=${pkgname}.install
+source=("${url}/releases/download/${pkgver}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst")
+sha256sums=('dbfd6ea2e6994f5157f5794049796a06ea94d424c41121f30181e6ff48fbcaa3')
+
+noextract=("rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst")
+
+prepare() {
+ bsdtar -xf "${srcdir}/rustdesk-${pkgver}-manjaro-arch.pkg.tar.zst"
+}
+
+package() {
+ cp -r "${srcdir}/usr" "${pkgdir}/"
+}