summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortaotieren2023-08-27 16:05:03 +0800
committertaotieren2023-08-27 16:05:03 +0800
commitf39986be8fd1ac5e019382072c36356c53178b6d (patch)
treeb82f67b8969b1552ea63c8186fdbba943b95f22e
parentf95573324d781e85305c93b54a57b3276d145771 (diff)
downloadaur-f39986be8fd1ac5e019382072c36356c53178b6d.tar.gz
Update 1.2.2.-2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD18
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a26491c639fe..6683c4b8f32c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = rustdesk-bin
pkgdesc = Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!
pkgver = 1.2.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rustdesk/rustdesk
- arch = x86_64
- arch = aarch64
license = GPL3
optdepends = libappindicator-gtk3: tray icon
optdepends = libayatana-appindicator: tray icon
options = !strip
source = rustdesk-1.2.2-x86_64.pkg.tar.zst::https://github.com/rustdesk/rustdesk/releases/download/1.2.2/rustdesk-1.2.2-0-x86_64.pkg.tar.zst
+ source = rustdesk-1.2.2-x86_64.AppImage::https://github.com/rustdesk/rustdesk/releases/download/1.2.2/rustdesk-1.2.2-x86_64.AppImage
+ source = rustdesk-1.2.2-aarch64.AppImage::https://github.com/rustdesk/rustdesk/releases/download/1.2.2/rustdesk-1.2.2-aarch64.AppImage
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
- source_x86_64 = rustdesk-1.2.2-x86_64.AppImage::https://github.com/rustdesk/rustdesk/releases/download/1.2.2/rustdesk-1.2.2-x86_64.AppImage
- sha256sums_x86_64 = SKIP
- source_aarch64 = rustdesk-1.2.2-aarch64.AppImage::https://github.com/rustdesk/rustdesk/releases/download/1.2.2/rustdesk-1.2.2-aarch64.AppImage
- sha256sums_aarch64 = SKIP
pkgname = rustdesk-bin
+ arch = x86_64
depends = gstreamer
depends = gst-plugins-base-libs
depends = gtk3
@@ -33,5 +32,7 @@ pkgname = rustdesk-bin
pkgname = rustdesk-appimage
pkgdesc = Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk! (AppImage)
+ arch = x86_64
+ arch = aarch64
provides = rustdesk
conflicts = rustdesk
diff --git a/PKGBUILD b/PKGBUILD
index 0e502919704f..250113b9abe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,8 @@
pkgbase=rustdesk-bin
pkgname=(rustdesk-{bin,appimage})
pkgver=1.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Yet another remote desktop software, written in Rust. Works out of the box, no configuration required. Great alternative to TeamViewer and AnyDesk!"
-arch=('x86_64' 'aarch64')
url="https://github.com/rustdesk/rustdesk"
license=('GPL3')
optdepends=(
@@ -14,13 +13,12 @@ optdepends=(
'libayatana-appindicator: tray icon'
)
options=('!strip')
-source=("${pkgbase%-bin}-${pkgver}-$CARCH.pkg.tar.zst::$url/releases/download/${pkgver}/rustdesk-${pkgver}-0-$CARCH.pkg.tar.zst")
-source_x86_64=("${pkgbase%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/${pkgver}/${pkgbase%-bin}-${pkgver}-x86_64.AppImage")
-source_aarch64=("${pkgbase%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/${pkgver}/${pkgbase%-bin}-${pkgver}-aarch64.AppImage")
-sha256sums=('SKIP')
-sha256sums_x86_64=('SKIP')
-sha256sums_aarch64=('SKIP')
-
+source=("${pkgbase%-bin}-${pkgver}-$CARCH.pkg.tar.zst::$url/releases/download/${pkgver}/rustdesk-${pkgver}-0-$CARCH.pkg.tar.zst"
+ "${pkgbase%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/${pkgver}/${pkgbase%-bin}-${pkgver}-x86_64.AppImage"
+ "${pkgbase%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/${pkgver}/${pkgbase%-bin}-${pkgver}-aarch64.AppImage")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
_install_path="/opt/appimages"
prepare() {
@@ -32,6 +30,7 @@ prepare() {
}
package_rustdesk-bin() {
+ arch=('x86_64')
provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
depends=(
@@ -65,6 +64,7 @@ package_rustdesk-bin() {
package_rustdesk-appimage() {
pkgdesc+=" (AppImage)"
+ arch=('x86_64' 'aarch64')
provides=("${pkgname%-appimage}")
conflicts=("${pkgname%-appimage}")