summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis Salmanovich2023-01-25 12:48:15 +0200
committerDenis Salmanovich2023-01-25 12:48:15 +0200
commitdafee3bca2e1e57450663aadce0899b624cf8d75 (patch)
treebd32d14107a647ae850776a83ced0666ad2893e9
downloadaur-rusted-shamus.tar.gz
version 0.1.1
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
-rw-r--r--rusted-shamus.desktop9
-rw-r--r--rusted-shamus_icon.pngbin0 -> 1227 bytes
4 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f3ecb499d8b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rusted-shamus
+ pkgdesc = Remake os the shamus game written in Rust
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/denix666/shamus
+ arch = x86_64
+ license = MIT
+ source = https://github.com/denix666/shamus/releases/download/v0.1.1/shamus_linux_x86_64.tar.gz
+ source = rusted-shamus_icon.png
+ source = rusted-shamus.desktop
+ sha256sums = 685263dae2ed8b5c57952156d52bf8e9f3e2052f04014c338677004937144505
+ sha256sums = 57d5647b0d9d4e691a9abbec69e0794f227b181dc5b20fcef4b2299dfc52f41b
+ sha256sums = 82c0d8837d08ea685ac8a0b2caf8ae8436fc7566ac6d0e2f58ab2e4189ccd87d
+
+pkgname = rusted-shamus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a088e957bfae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=rusted-shamus
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Remake os the shamus game written in Rust"
+arch=('x86_64')
+url='https://github.com/denix666/shamus'
+license=('MIT')
+
+source=('https://github.com/denix666/shamus/releases/download/v0.1.1/shamus_linux_x86_64.tar.gz'
+ 'rusted-shamus_icon.png'
+ 'rusted-shamus.desktop')
+
+package() {
+ cd ${srcdir}
+ install -d -m755 ${pkgdir}/usr/local/games/${pkgname}
+ install -D -m755 shamus ${pkgdir}/usr/local/games/${pkgname}/shamus
+ cp -r ${srcdir}/assets ${pkgdir}/usr/local/games/${pkgname}
+ install -D -m644 rusted-shamus_icon.png ${pkgdir}/usr/share/pixmaps/rusted-shamus_icon.png
+ install -D -m644 rusted-shamus.desktop ${pkgdir}/usr/share/applications/rusted-shamus.desktop
+}
+sha256sums=('685263dae2ed8b5c57952156d52bf8e9f3e2052f04014c338677004937144505'
+ '57d5647b0d9d4e691a9abbec69e0794f227b181dc5b20fcef4b2299dfc52f41b'
+ '82c0d8837d08ea685ac8a0b2caf8ae8436fc7566ac6d0e2f58ab2e4189ccd87d')
diff --git a/rusted-shamus.desktop b/rusted-shamus.desktop
new file mode 100644
index 000000000000..0c23ed0c8a03
--- /dev/null
+++ b/rusted-shamus.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Exec=bash -c 'cd /usr/local/games/rusted-shamus && ./shamus'
+Icon=/usr/share/pixmaps/rusted-shamus_icon.png
+Name=Rusted shamus
+Terminal=false
+Type=Application
+Categories=GNOME;GTK;Game;
+Encoding=UTF-8
+Comment=Shamus - remake written in Rust
diff --git a/rusted-shamus_icon.png b/rusted-shamus_icon.png
new file mode 100644
index 000000000000..47a7a1026fa7
--- /dev/null
+++ b/rusted-shamus_icon.png
Binary files differ