summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-08-19 23:08:12 +0300
committervlad2015-08-19 23:08:12 +0300
commita95c9364c14857f42195f571dfac013c15ce509a (patch)
tree7f47c086ded8ee45e7d3e396aab238be05ebb8bf
downloadaur-a95c9364c14857f42195f571dfac013c15ce509a.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD31
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24a5b82094c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rusti-git
+ pkgdesc = REPL for the Rust
+ pkgver = r121.13b5940
+ pkgrel = 1
+ url = https://github.com/murarth/rusti
+ arch = i686
+ arch = x86_64
+ license = Apache
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ depends = rust
+ provides = rusti
+ conflicts = rusti
+ source = git+https://github.com/murarth/rusti.git
+ sha256sums = SKIP
+
+pkgname = rusti-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0a8537aadb4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Vlad M. <vlad@archlinux.net>
+
+pkgname=rusti-git
+_pkgname=rusti
+pkgver=r121.13b5940
+pkgrel=1
+pkgdesc="REPL for the Rust"
+url="https://github.com/murarth/rusti"
+depends=('rust')
+makedepends=('git' 'cargo')
+provides=('rusti')
+conflicts=('rusti')
+arch=('i686' 'x86_64')
+license=('Apache' 'MIT')
+source=("git+https://github.com/murarth/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname/target/release/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$srcdir/$_pkgname/"{LICENSE-APACHE,LICENSE-MIT} "$pkgdir/usr/share/licenses/$pkgname/"
+}