summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwojciechkepka2020-05-06 18:56:27 +0200
committerwojciechkepka2020-05-06 18:56:27 +0200
commit322bdedd67ff299e060aa65991a75cd8720bc594 (patch)
tree21ba60d564bbe60d9412ab0567b6c3add054a835
parent0c41fbf83e7a06d9773343823f2c6cfc32d12a82 (diff)
downloadaur-322bdedd67ff299e060aa65991a75cd8720bc594.tar.gz
More appropriate version with last git commit
-rw-r--r--PKGBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b929cc2f6fef..9467bd70803e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,6 +19,11 @@ build() {
cargo build --release
}
+pkgver() {
+ cd "$pkgname"
+ echo "$(git log -1 --format=%cd.%h --date=short|tr -d -)"
+}
+
package() {
cd "$pkgname"
install -Dm755 "target/release/rustop" "$pkgdir/usr/bin/rustop"