summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwojciechkepka2020-05-06 18:47:11 +0200
committerwojciechkepka2020-05-06 18:47:11 +0200
commita58370a3faa85122a511d04c488aa409e3315e60 (patch)
treea9c2cfd08bb38ac3d6b6313810774ed6b85e2a28
downloadaur-a58370a3faa85122a511d04c488aa409e3315e60.tar.gz
rustop first release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9997b4ca56f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rustop
+ pkgdesc = All important information about your system in one place
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/wojciechkepka/rustop
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = cargo
+ makedepends = git
+ provides = rustop
+ conflicts = rustop
+ source = rustop::git+https://github.com/wojciechkepka/rustop
+ sha1sums = SKIP
+
+pkgname = rustop
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..503d3c2dd792
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Wojciech Kepka <wojtek.kepka@protonmail.com>
+pkgname=rustop
+pkgver=0.5.0
+pkgrel=1
+epoch=
+pkgdesc="All important information about your system in one place"
+arch=('x86_64' 'i686')
+url="https://github.com/wojciechkepka/rustop"
+license=('MIT')
+depends=()
+makedepends=('cargo' 'git')
+provides=("rustop")
+conflicts=("rustop")
+sha1sums=('SKIP')
+source=("$pkgname::git+https://github.com/wojciechkepka/rustop")
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm644 "target/release/rustop" "$pkgdir/usr/bin/rustop"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}