summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerman Lashevich2019-12-15 22:28:19 +0100
committerGerman Lashevich2019-12-15 22:28:19 +0100
commitbecb192bc5ca0526feabeb4863addfdf585d2172 (patch)
tree0b066b1d48ce06c6ce0fac8271afbf4014e00092
downloadaur-becb192bc5ca0526feabeb4863addfdf585d2172.tar.gz
Initial version
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..330bcbfa9004
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = rustotpony
+ pkgdesc = 🐴 RusTOTPony — CLI manager of one-time password generators aka Google Authenticator
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://github.com/zebradil/rustotpony
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = MIT
+ makedepends = rust
+ makedepends = cargo
+ provides = totp
+ conflicts = rustotpony-git
+ source = rustotpony-0.2.6::https://github.com/zebradil/rustotpony/archive/0.2.6.tar.gz
+ sha1sums = 4a4634ea51ad9b40de09763f532087bfb9b0e142
+
+pkgname = rustotpony
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8282b37e6dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: German Lashevich <german.lashevich@gmail.com>
+
+_binname=totp
+
+pkgname=rustotpony
+pkgver=0.2.6
+pkgrel=1
+pkgdesc='🐴 RusTOTPony — CLI manager of one-time password generators aka Google Authenticator'
+provides=('totp')
+conflicts=('rustotpony-git')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+url="https://github.com/zebradil/${pkgname}"
+license=('MIT')
+# depends=('libx11' 'libxkbfile')
+makedepends=('rust' 'cargo')
+source=("${pkgname}-${pkgver}::https://github.com/zebradil/${pkgname}/archive/${pkgver}.tar.gz")
+sha1sums=('4a4634ea51ad9b40de09763f532087bfb9b0e142')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ cargo build --release
+}
+
+package() {
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}/target/release/${_binname}" "${pkgdir}/usr/bin/${_binname}"
+}