summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerman Lashevich2019-12-16 13:36:27 +0100
committerGerman Lashevich2019-12-16 13:36:27 +0100
commita83b22d1fcd39f55a6db5eee7a56d57f0c7c6d21 (patch)
tree1b876f55c77b5f53f8ffa779b1be06278d34d02b
downloadaur-a83b22d1fcd39f55a6db5eee7a56d57f0c7c6d21.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baa69326c1cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rustotpony-bin
+ pkgdesc = RusTOTPony — CLI manager of one-time password generators aka Google Authenticator
+ pkgver = 0.2.6
+ pkgrel = 1
+ url = https://github.com/zebradil/rustotpony
+ arch = x86_64
+ license = MIT
+ provides = totp
+ conflicts = rustotpony
+ conflicts = rustotpony-git
+ source = https://github.com/zebradil/rustotpony/releases/download/0.2.6/totp-linux
+ sha256sums = 7fd4c34398a63dcf3189db91ba2dbe9c1d8b96a0a04814ef56b8e764b145e608
+
+pkgname = rustotpony-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef0b862f6e59
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: German Lashevich <german.lashevich@gmail.com>
+
+_binname=totp
+
+pkgname=rustotpony-bin
+_pkgname=${pkgname%-bin}
+pkgver=0.2.6
+pkgrel=1
+pkgdesc='RusTOTPony — CLI manager of one-time password generators aka Google Authenticator'
+provides=(${_binname})
+conflicts=(${_pkgname} ${_pkgname}-git)
+arch=(x86_64)
+url="https://github.com/zebradil/${_pkgname}"
+license=('MIT')
+source=("${url}/releases/download/${pkgver}/${_binname}-linux")
+# source=("${url}/releases/download/${pkgver}/${_pkgname}_${pkgver}_linux_${_arch}.tgz")
+sha256sums=("7fd4c34398a63dcf3189db91ba2dbe9c1d8b96a0a04814ef56b8e764b145e608")
+
+package() {
+ install -Dm755 "${srcdir}/${_binname}-linux" "${pkgdir}/usr/bin/${_binname}"
+}