summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfordprefect2019-02-07 11:34:28 +0100
committerfordprefect2019-02-07 11:34:28 +0100
commitd2aa28fd20c20076b7c6aae0c9d090e75f51d562 (patch)
treeac0fb31fe02e46c1b6a3ef585c7b1c78c901326f
downloadaur-d2aa28fd20c20076b7c6aae0c9d090e75f51d562.tar.gz
import of rustpython to AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3054230b062b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Thu Feb 7 10:33:59 UTC 2019
+pkgbase = rustpython-git
+ pkgdesc = A Python3 Interpreter written in Rust
+ pkgver = r1018.d3158f3
+ pkgrel = 1
+ url = https://github.com/RustPython/RustPython
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = rust
+ source = git+https://github.com/RustPython/RustPython.git
+ md5sums = SKIP
+
+pkgname = rustpython-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3810566656b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+pkgname="rustpython-git"
+pkgver=r1018.d3158f3
+pkgrel=1
+pkgdesc='A Python3 Interpreter written in Rust'
+arch=('x86_64' 'i686')
+url='https://github.com/RustPython/RustPython'
+#depends=('')
+makedepends=('rust')
+license=('MIT')
+source=('git+https://github.com/RustPython/RustPython.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd RustPython
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/RustPython"
+ cargo build --release --locked
+}
+
+check() {
+ cd "$srcdir/RustPython"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$srcdir/RustPython"
+ install -Dm755 target/release/rustpython -t "$pkgdir/usr/bin"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}