summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kolchenko2021-07-12 16:57:55 +0300
committerAndrey Kolchenko2021-07-12 16:57:55 +0300
commit31cfa294ce9aca6a42780d8cf322548ca42f7203 (patch)
tree1bdb87b99ce82574de5b0585af2b11e49a3b5de9
downloadaur-31cfa294ce9aca6a42780d8cf322548ca42f7203.tar.gz
First build of rutoken-plugin package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0e7fb089710f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rutoken-plugin
+ pkgdesc = The Rutoken plugin is necessary for connecting USB devices with the browser, it allows you to identify devices and work with them.
+ pkgver = 4.5.5
+ pkgrel = 1
+ url = https://www.rutoken.ru/support/download/rutoken-plugin/
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = findutils
+ depends = sed
+ source_i686 = rutoken-plugin-4.5.5.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.5.0/Linux/libnpRutokenPlugin-4.5.5-1.i686.rpm
+ sha256sums_i686 = ca9af2f16d1851a67c5803cc87f20bb5c29dcfb93fe9b9124c75d4b1702b0678
+ source_x86_64 = rutoken-plugin-4.5.5.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.5.0/Linux/libnpRutokenPlugin-4.5.5-1.x86_64.rpm
+ sha256sums_x86_64 = 1b7a8880653425c3e6ccff565f8ee9dded991bff35dc526f2394886f6cb7580b
+
+pkgname = rutoken-plugin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..41c9fc72893d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Andrey Kolchenko <andrey@kolchenko.me>
+
+pkgname=rutoken-plugin
+pkgver=4.5.5
+pkgrel=1
+pkgdesc="The Rutoken plugin is necessary for connecting USB devices with the browser, it allows you to identify devices and work with them."
+arch=('i686' 'x86_64')
+url="https://www.rutoken.ru/support/download/rutoken-plugin/"
+license=('unknown')
+depends=("findutils" "sed")
+
+source_x86_64=("${pkgname}-${pkgver}.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.5.0/Linux/libnpRutokenPlugin-4.5.5-1.x86_64.rpm")
+sha256sums_x86_64=("1b7a8880653425c3e6ccff565f8ee9dded991bff35dc526f2394886f6cb7580b")
+source_i686=("${pkgname}-${pkgver}.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.5.0/Linux/libnpRutokenPlugin-4.5.5-1.i686.rpm")
+sha256sums_i686=("ca9af2f16d1851a67c5803cc87f20bb5c29dcfb93fe9b9124c75d4b1702b0678")
+
+package() {
+ find "${srcdir}" -type d | sed "s#^${srcdir}#${pkgdir}#g" | tail -n +2 | xargs install -d
+ eval $(find ${srcdir} -type f -exec bash -c 'echo install \"{}\" \"@$(dirname {})\"\;' \; | sed "s#@${srcdir}#${pkgdir}#g")
+ eval $(find ${srcdir} -type l -exec bash -c 'echo ln -s \"$(readlink {})\" \"@{}\"\;' \; | grep -v '.rpm' | sed "s#@${srcdir}#${pkgdir}#g")
+}