summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Kolchenko2021-10-18 11:46:00 +0300
committerAndrey Kolchenko2021-10-18 11:46:00 +0300
commit804ae9cde0e57418e2ef17c288e15872990af1a4 (patch)
tree285e270f2de55e4611b0ff7a849affd7225cc324
parent4bef9a2af70c8e5d661153b04cd4805ffaeea55b (diff)
downloadaur-804ae9cde0e57418e2ef17c288e15872990af1a4.tar.gz
Update package version
Do not put files into /usr/lib64
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43fc4cb25629..6693d0e273c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rutoken-plugin
pkgdesc = The Rutoken plugin is necessary for connecting USB devices with the browser, it allows you to identify devices and work with them.
- pkgver = 4.5.5
- pkgrel = 2
+ pkgver = 4.5.6
+ pkgrel = 1
url = https://www.rutoken.ru/support/download/rutoken-plugin/
arch = i686
arch = x86_64
@@ -11,9 +11,9 @@ pkgbase = rutoken-plugin
makedepends = grep
makedepends = coreutils
makedepends = bash
- source_i686 = rutoken-plugin-4.5.5.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.5.0/Linux/libnpRutokenPlugin-4.5.5-1.i686.rpm
- sha256sums_i686 = ca9af2f16d1851a67c5803cc87f20bb5c29dcfb93fe9b9124c75d4b1702b0678
- source_x86_64 = rutoken-plugin-4.5.5.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.5.0/Linux/libnpRutokenPlugin-4.5.5-1.x86_64.rpm
- sha256sums_x86_64 = 1b7a8880653425c3e6ccff565f8ee9dded991bff35dc526f2394886f6cb7580b
+ source_i686 = rutoken-plugin-4.5.6.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.6.0/Linux/libnpRutokenPlugin-4.5.6-1.i686.rpm
+ sha256sums_i686 = 8f5c8fb368bb67cd8114c64d30b7d5068055a4734331bd233bee4c12359b1c40
+ source_x86_64 = rutoken-plugin-4.5.6.rpm::https://download.rutoken.ru/Rutoken_Plugin/4.5.6.0/Linux/libnpRutokenPlugin-4.5.6-1.x86_64.rpm
+ sha256sums_x86_64 = b693dd8873b9a9b5b11aa399fc194a197ce4d2f66933d2b535c420d41e1f31b5
pkgname = rutoken-plugin
diff --git a/PKGBUILD b/PKGBUILD
index c3da266224e1..0c3faaf6e4b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Contributor: Andrey Kolchenko <andrey@kolchenko.me>
pkgname=rutoken-plugin
-pkgver=4.5.5
-pkgrel=2
+pkgver=4.5.6
+pkgrel=1
pkgdesc="The Rutoken plugin is necessary for connecting USB devices with the browser, it allows you to identify devices and work with them."
arch=('i686' 'x86_64')
url="https://www.rutoken.ru/support/download/rutoken-plugin/"
@@ -10,11 +10,13 @@ license=('unknown')
makedepends=("findutils" "sed" "grep" "coreutils" "bash")
source_x86_64=("${pkgname}-${pkgver}.rpm::https://download.rutoken.ru/Rutoken_Plugin/${pkgver}.0/Linux/libnpRutokenPlugin-${pkgver}-1.x86_64.rpm")
-sha256sums_x86_64=("1b7a8880653425c3e6ccff565f8ee9dded991bff35dc526f2394886f6cb7580b")
+sha256sums_x86_64=("b693dd8873b9a9b5b11aa399fc194a197ce4d2f66933d2b535c420d41e1f31b5")
source_i686=("${pkgname}-${pkgver}.rpm::https://download.rutoken.ru/Rutoken_Plugin/${pkgver}.0/Linux/libnpRutokenPlugin-${pkgver}-1.i686.rpm")
-sha256sums_i686=("ca9af2f16d1851a67c5803cc87f20bb5c29dcfb93fe9b9124c75d4b1702b0678")
+sha256sums_i686=("8f5c8fb368bb67cd8114c64d30b7d5068055a4734331bd233bee4c12359b1c40")
package() {
+ mv "${srcdir}/usr/lib64/mozilla/native-messaging-hosts" "${srcdir}/usr/lib/mozilla/"
+ rm -rf "${srcdir}/usr/lib64"
find "${srcdir}" -type d | sed "s#^${srcdir}#${pkgdir}#g" | tail -n +2 | xargs install -d
eval $(find ${srcdir} -type f -exec bash -c 'echo install \"{}\" \"@$(dirname {})\"\;' \; | sed "s#@${srcdir}#${pkgdir}#g")
eval $(find ${srcdir} -type l -exec bash -c 'echo ln -s \"$(readlink {})\" \"@{}\"\;' \; | grep -v '.rpm' | sed "s#@${srcdir}#${pkgdir}#g")