summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-06-14 16:42:16 +0200
committerPiotr Rogoża2015-06-14 16:42:16 +0200
commit702bc1e4b8b2069bb632ffa427985e71bbd9d633 (patch)
tree1b75630740e3d4bc83206a0bd6675040c06382f5
downloadaur-702bc1e4b8b2069bb632ffa427985e71bbd9d633.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD55
-rw-r--r--apache.example.conf14
-rw-r--r--apache.example.site.conf36
4 files changed, 132 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07330222ed8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = rutorrent
+ pkgdesc = Yet another web front-end for rTorrent
+ pkgver = 3.7
+ pkgrel = 4
+ url = http://code.google.com/p/rutorrent/
+ arch = any
+ license = GPL
+ depends = php
+ depends = curl
+ depends = gzip
+ depends = coreutils
+ optdepends = mod_scgi: for SCGI protocol
+ conflicts = rutorrent-plugins
+ options = emptydirs
+ options = !strip
+ backup = etc/webapps/rutorrent/conf/config.php
+ backup = etc/webapps/rutorrent/conf/plugins.ini
+ backup = etc/webapps/rutorrent/conf/access.ini
+ source = rutorrent-3.7.zip::http://dl.bintray.com/novik65/generic/ruTorrent-3.7.zip
+ source = apache.example.conf
+ source = apache.example.site.conf
+ sha256sums = c1fb86317231c8e8fa9e1a7dea450ce4687d94caad22d763bc68d90c56d0749f
+ sha256sums = 79b5aab7ef928727b3ec2aa0f1b0869310adde11cd774d148c03025deb6dec0c
+ sha256sums = 9afe7d2a9aadb5fd6a0fcd907f7f46bdc3630c369a5a684c51bbeeb5b4d354aa
+
+pkgname = rutorrent
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..20d97df3a046
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+# Contributor: Sergei Lebedev <superbobry at gmail dot com>
+
+pkgname=rutorrent
+_pkgname=ruTorrent-master
+pkgver=3.7
+pkgrel=4
+pkgdesc="Yet another web front-end for rTorrent"
+arch=('any')
+url="http://code.google.com/p/rutorrent/"
+license=('GPL')
+depends=(php curl gzip coreutils)
+optdepends=('mod_scgi: for SCGI protocol')
+conflicts=(rutorrent-plugins)
+source=(
+$pkgname-$pkgver.zip::"http://dl.bintray.com/novik65/generic/ruTorrent-$pkgver.zip"
+apache.example.conf
+apache.example.site.conf)
+sha256sums=('c1fb86317231c8e8fa9e1a7dea450ce4687d94caad22d763bc68d90c56d0749f'
+ '79b5aab7ef928727b3ec2aa0f1b0869310adde11cd774d148c03025deb6dec0c'
+ '9afe7d2a9aadb5fd6a0fcd907f7f46bdc3630c369a5a684c51bbeeb5b4d354aa')
+backup=(
+etc/webapps/rutorrent/conf/config.php
+etc/webapps/rutorrent/conf/plugins.ini
+etc/webapps/rutorrent/conf/access.ini
+)
+options=(emptydirs !strip)
+prepare() {
+ cd $srcdir/$_pkgname
+ rm .gitignore
+}
+
+package() {
+ cd $srcdir/$_pkgname
+
+ install -d "$pkgdir"/usr/share/webapps
+ install -d "$pkgdir"/etc/webapps/$pkgname
+
+ cp -r conf "$pkgdir"/etc/webapps/$pkgname/
+ cp -r . "$pkgdir"/usr/share/webapps/$pkgname/
+
+ rm -rf "$pkgdir"/usr/share/webapps/$pkgname/conf
+
+ install -Dm644 ../apache.example.conf "$pkgdir"/etc/webapps/rutorrent/
+ install -Dm644 ../apache.example.site.conf "$pkgdir"/etc/webapps/rutorrent/
+
+ cd "$pkgdir"/usr/share/webapps/$pkgname
+ ln -s /etc/webapps/$pkgname/conf
+
+ #fix perms
+ #chown http\: $pkgdir/usr/share/webapps/$pkgname/share/{settings,torrents,users}
+ chmod 0777 $pkgdir/usr/share/webapps/$pkgname/share/{settings,torrents,users}
+
+}
diff --git a/apache.example.conf b/apache.example.conf
new file mode 100644
index 000000000000..e3a848f92ebd
--- /dev/null
+++ b/apache.example.conf
@@ -0,0 +1,14 @@
+<IfModule alias_module>
+ Alias /rutorrent /usr/share/webapps/rutorrent
+ <Directory "/usr/share/webapps/rutorrent">
+ AllowOverride None
+ Options None
+ Order allow,deny
+# Allow from all
+ Allow from 127.0.0.1
+ Allow from ::1
+ </Directory>
+</IfModule>
+
+# vim:ft=apache
+
diff --git a/apache.example.site.conf b/apache.example.site.conf
new file mode 100644
index 000000000000..0dd23cc59c9e
--- /dev/null
+++ b/apache.example.site.conf
@@ -0,0 +1,36 @@
+#NameVirtualHost *
+
+<VirtualHost *>
+ ServerName rutorrent.localhost
+ ServerAdmin webmaster@localhost
+ DocumentRoot /usr/share/webapps/rutorrent
+
+# change HTTPD to the httpd.itk in /etc/conf.d/apache
+ <IfModule itk.c>
+ AssignUserId user group
+ </IfModule>
+
+ <Directory "/usr/share/webapps/rutorrent">
+ AllowOverride All
+ AuthName "Private"
+ AuthType Basic
+# from root or sudo run: htpasswd -c /etc/webapps/rutorrent/conf/htpasswd your.username
+ AuthUserFile /etc/webapps/rutorrent/conf/htpasswd
+ Require valid-user
+ Order allow,deny
+# Allow from all
+ Allow from 127.0.0.1
+ Allow from ::1
+ </Directory>
+
+ <IfModule scgi_module>
+ SCGIMount /RPC2 localhost:5000
+ </IfModule>
+
+ # first create the directory
+ ErrorLog /var/log/httpd/rutorrent.localhost/error.log
+ CustomLog /var/log/httpd/rutorrent.localhost/access.log combined
+</VirtualHost>
+
+# vim:ft=apache
+