summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGoliathLabs2020-05-10 13:03:32 +0200
committerGoliathLabs2020-05-10 13:03:32 +0200
commit7e11ad2e534dae875c086dddb05a227ee9ddebb4 (patch)
treefdc61c12898780962e6c3a98b5ac2cb51f47bfb7
parent3eca093f50a2c18f5894f2c4dc0ffcce8dd55397 (diff)
downloadaur-7e11ad2e534dae875c086dddb05a227ee9ddebb4.tar.gz
Updated: 3.10-beta
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6831cdbd1c1..0b1dee07afb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rutorrent
pkgdesc = Yet another web front-end for rTorrent
- pkgver = 3.9
+ pkgver = 3.10_beta
pkgrel = 1
url = https://github.com/Novik/ruTorrent
arch = any
@@ -16,10 +16,10 @@ pkgbase = rutorrent
backup = etc/webapps/rutorrent/conf/config.php
backup = etc/webapps/rutorrent/conf/plugins.ini
backup = etc/webapps/rutorrent/conf/access.ini
- source = rutorrent-3.9.tar.gz::https://github.com/Novik/ruTorrent/archive/v3.9.tar.gz
+ source = rutorrent-3.10_beta.tar.gz::https://github.com/Novik/ruTorrent/archive/v3.10-beta.tar.gz
source = apache.example.conf
source = apache.example.site.conf
- sha256sums = 610fc5df350fe7915b4413067fea8657eb6f26b1cc5212de97a4af98439b2e2c
+ sha256sums = 2c329725f267e024118bd809996b65302f3df7a447b07834fd889597a1e32475
sha256sums = 79b5aab7ef928727b3ec2aa0f1b0869310adde11cd774d148c03025deb6dec0c
sha256sums = 9afe7d2a9aadb5fd6a0fcd907f7f46bdc3630c369a5a684c51bbeeb5b4d354aa
diff --git a/PKGBUILD b/PKGBUILD
index df1c770a66d7..01270f9368d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
-# Maintainer: David Birks <david@tellus.space>
+# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Contributor: David Birks <david@tellus.space>
# Contributor: Piotr Rogoza <piotr dot r dot public at gmail dot com>
# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
# Contributor: Sergei Lebedev <superbobry at gmail dot com>
pkgname=rutorrent
_pkgname=ruTorrent
-pkgver=3.9
+pkgver=3.10_beta
+_pkgver=3.10-beta
pkgrel=1
pkgdesc="Yet another web front-end for rTorrent"
arch=('any')
@@ -15,11 +17,11 @@ depends=(php curl gzip coreutils)
optdepends=('mod_scgi: for SCGI protocol')
conflicts=(rutorrent-plugins)
source=(
- $pkgname-$pkgver.tar.gz::https://github.com/Novik/ruTorrent/archive/v${pkgver}.tar.gz
+ $pkgname-$pkgver.tar.gz::https://github.com/Novik/ruTorrent/archive/v${_pkgver}.tar.gz
apache.example.conf
apache.example.site.conf
)
-sha256sums=('ff9b9dc21c4523603d2a415908455aa4376f0890412cf857690acbea29c15c76'
+sha256sums=('2c329725f267e024118bd809996b65302f3df7a447b07834fd889597a1e32475'
'79b5aab7ef928727b3ec2aa0f1b0869310adde11cd774d148c03025deb6dec0c'
'9afe7d2a9aadb5fd6a0fcd907f7f46bdc3630c369a5a684c51bbeeb5b4d354aa')
backup=(
@@ -30,14 +32,14 @@ backup=(
options=(emptydirs !strip)
prepare() {
- cd $srcdir/$_pkgname-$pkgver
+ cd $srcdir/$_pkgname-$_pkgver
rm -f .gitignore
msg2 "Removing files with Russian letters in filenames"
cd plugins/tracklabels/labels
find . -print0 | perl -MFile::Path=remove_tree -n0e 'chomp; remove_tree($_, {verbose=>1}) if /[[:^ascii:][:cntrl:]]/'
}
package() {
- cd $srcdir/$_pkgname-$pkgver
+ cd $srcdir/$_pkgname-$_pkgver
install -d "$pkgdir"/usr/share/webapps
install -d "$pkgdir"/etc/webapps/$pkgname