summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHans-Nikolai Viessmann2016-06-26 14:11:50 +0100
committerHans-Nikolai Viessmann2016-06-26 14:11:50 +0100
commitce1b35fa37f31831099572dabef07df7c0981a4e (patch)
tree9513d8b6997e584cee8206d1b30a8fdba0db0e74
downloadaur-ce1b35fa37f31831099572dabef07df7c0981a4e.tar.gz
Initial commit of version 1.62
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--rutorrent-autodl-irssi-community.install10
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd012bbeb339
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rutorrent-autodl-irssi-community
+ pkgdesc = Community fork of the autodl-irssi rutorrent plugin.
+ pkgver = 1.62
+ pkgrel = 1
+ url = http://sourceforge.net/projects/autodl-irssi
+ install = rutorrent-autodl-irssi-community.install
+ arch = any
+ license = MPL
+ depends = rutorrent
+ depends = autodl-irssi-community=1.62
+ provides = rutorrent-autodl-irssi
+ replaces = rutorrent-autodl-irssi-svn
+ source = https://github.com/autodl-community/autodl-rutorrent/archive/community-v1.62.tar.gz
+ md5sums = e5880da80fdda8e75c5b97a140c5a6d1
+
+pkgname = rutorrent-autodl-irssi-community
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e184dfc468cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Hans-Nikolai Viessmann <hv15 AT hw.ac.uk>
+# Contributor: Guten Ye
+
+pkgname='rutorrent-autodl-irssi-community'
+_pkgname='autodl-rutorrent-community'
+pkgver=1.62
+pkgrel=1
+pkgdesc='Community fork of the autodl-irssi rutorrent plugin.'
+arch=('any')
+url='http://sourceforge.net/projects/autodl-irssi'
+license=('MPL')
+install='rutorrent-autodl-irssi-community.install'
+depends=('rutorrent' "autodl-irssi-community=${pkgver}")
+provides=('rutorrent-autodl-irssi')
+replaces=('rutorrent-autodl-irssi-svn')
+source=("https://github.com/autodl-community/autodl-rutorrent/archive/community-v${pkgver}.tar.gz")
+md5sums=('e5880da80fdda8e75c5b97a140c5a6d1')
+
+build() {
+ cd "$srcdir/$_pkgname-v$pkgver"
+ mv _conf.php conf.php
+}
+
+package() {
+ cd "$srcdir/$_pkgname-v$pkgver"
+
+ install -dm755 "$pkgdir/usr/share/webapps/rutorrent/plugins/autodl-irssi"
+ cp -r * "$pkgdir/usr/share/webapps/rutorrent/plugins/autodl-irssi"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/rutorrent-autodl-irssi-community.install b/rutorrent-autodl-irssi-community.install
new file mode 100644
index 000000000000..f081b347ee7f
--- /dev/null
+++ b/rutorrent-autodl-irssi-community.install
@@ -0,0 +1,10 @@
+post_install () {
+ cat << EOF
+Please read the install instructions at:
+https://github.com/autodl-community/autodl-rutorrent/wiki
+
+Specifically, make sure your PHP install has sockets, json, and xml
+support activated. Check your \`php.ini' file.
+EOF
+}
+