summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-24 12:34:51 -0400
committerskydrome2015-06-24 12:34:51 -0400
commitb1b3bd709e4eaca2198b65ac3e89342baaeec825 (patch)
treeab058f30db334a0a876672ab4a811670f9c2bfee
parent21ea640fd9ab9059d3571057d47e26a7a410386f (diff)
downloadaur-b1b3bd709e4eaca2198b65ac3e89342baaeec825.tar.gz
subverison no longer a build dep, switch to github for extra plugins
restructure a bit
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD33
3 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a87ac97ea690..1fcbf65bd1d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -27,18 +27,12 @@ pkgbase = rutorrent-git
source = https://raw.githubusercontent.com/weixiyen/jquery-filedrop/master/jquery.filedrop.js
source = rutorrent::git+https://github.com/Novik/ruTorrent.git
source = titlebar::git+https://github.com/SanKen/rutorrent-titlebar.git
- source = filemanager::svn+http://svn.rutorrent.org/svn/filemanager/trunk/filemanager
- source = fileshare::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileshare
- source = fileupload::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileupload
- source = mediastream::svn+http://svn.rutorrent.org/svn/filemanager/trunk/mediastream
+ source = extra::git+https://github.com/nelu/rutorrent-thirdparty-plugins.git
md5sums = a3efa833b362ac7f3ff69ddaa720de81
md5sums = 020b0c3fc1220d490992473a75485add
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
pkgname = rutorrent-git
diff --git a/.gitignore b/.gitignore
index f92036ee3753..f7591d37d238 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+extra/
chat/
file*/
mediastream/
diff --git a/PKGBUILD b/PKGBUILD
index 52df7f6b94d4..d52d474cba78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ install=rutorrent.install
options=(!strip)
depends=('php' 'curl' 'mktorrent')
-makedepends=('git' 'subversion')
+makedepends=('git')
optdepends=('php-geoip: enable geoip plugin'
'geoip: enable geoip plugin'
'unrar: enable unpack plugin'
@@ -27,24 +27,22 @@ backup=("${_webdir}/rutorrent/conf/config.php"
"${_webdir}/rutorrent/conf/access.ini"
"${_webdir}/rutorrent/conf/plugins.ini")
-_plugins=('filemanager' 'fileshare' 'fileupload' 'mediastream' 'titlebar')
+_plugins=('extra/filemanager'
+ 'extra/fileshare'
+ 'extra/fileupload'
+ 'extra/mediastream'
+ 'titlebar')
source=("plugins.ini"
"https://raw.githubusercontent.com/weixiyen/jquery-filedrop/master/jquery.filedrop.js"
"rutorrent::git+https://github.com/Novik/ruTorrent.git"
"titlebar::git+https://github.com/SanKen/rutorrent-titlebar.git"
- "filemanager::svn+http://svn.rutorrent.org/svn/filemanager/trunk/filemanager"
- "fileshare::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileshare"
- "fileupload::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileupload"
- "mediastream::svn+http://svn.rutorrent.org/svn/filemanager/trunk/mediastream")
+ "extra::git+https://github.com/nelu/rutorrent-thirdparty-plugins.git")
md5sums=('a3efa833b362ac7f3ff69ddaa720de81'
'020b0c3fc1220d490992473a75485add'
'SKIP'
'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
'SKIP')
pkgver() {
@@ -63,14 +61,13 @@ prepare() {
-e "s:\$XMLRPCMountPoint .*:\$XMLRPCMountPoint = \"/rutorrent/RPC1\";:" \
-e "s:\$tempDirectory .*:\$tempDirectory = '/${_webdir}/rutorrent/tmp';:"
-
for i in php stat curl id gzip; do
sed -i conf/config.php \
-e "s:\"$i\".*=> ''.*:\"$i\" => \'$(which $i)\',:"
done
for i in rar zip unzip unrar tar; do
- sed -i ../filemanager/conf.php \
+ sed -i ../extra/filemanager/conf.php \
-e "s:\$pathToExternals\['$i'\] = '':\$pathToExternals\['$i'\] = '$(which $i)':"
sed -i plugins/unpack/conf.php \
-e "s:\$pathToExternals\['$i'\] = '':\$pathToExternals\['$i'\] = '$(which $i)':"
@@ -95,16 +92,22 @@ package() {
cd "$srcdir/rutorrent/plugins"
for i in ${_plugins[@]}; do
- cp -r "$srcdir/$i" .
+ rm -rf "$srcdir/$i/.git"
+ cp -r "$srcdir/$i" .
done
- cp -f "$srcdir/jquery.filedrop.js" filedrop/jquery.filedrop.js
+
+ cp -f "$srcdir/jquery.filedrop.js" filedrop/jquery.filedrop.js
install -dm755 "$pkgdir/$_webdir"
+
cd "$pkgdir/$_webdir"
cp -r "$srcdir/rutorrent" .
rm -r rutorrent/{.git*,README*}
- install -Dm755 "$srcdir/plugins.ini" rutorrent/conf/plugins.ini
- mkdir -p rutorrent/tmp
+ cd rutorrent
+
+ install -Dm755 "$srcdir/plugins.ini" conf/plugins.ini
+ mkdir -p tmp
+ cp share/.htaccess tmp/
}