summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2017-06-15 15:00:58 -0400
committerYour Name2017-06-15 15:00:58 -0400
commitcb0c658aedc5f529f2783384cad17cae7884e29c (patch)
tree1fce36e0b6ac40d8e8f8804141123015c3f829ac
parent823d32b0cbd0efbdc42e4c868097216c90f4cba6 (diff)
downloadaur-cb0c658aedc5f529f2783384cad17cae7884e29c.tar.gz
update
add themes
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
-rwxr-xr-xplugins.ini2
3 files changed, 35 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3596862cb7b2..056ec6aba0a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri May 26 23:54:33 UTC 2017
+# Thu Jun 15 19:00:56 UTC 2017
pkgbase = rutorrent-git
pkgdesc = Web frontend to rTorrent in PHP designed to resemble uTorrent
- pkgver = r1953.d40e7955
+ pkgver = r1974.9191af0c
pkgrel = 1
url = https://github.com/Novik/ruTorrent
install = rutorrent.install
@@ -29,12 +29,20 @@ pkgbase = rutorrent-git
source = https://raw.githubusercontent.com/weixiyen/jquery-filedrop/master/jquery.filedrop.js
source = rutorrent::git+https://github.com/Novik/ruTorrent.git
source = titlebar::git+https://github.com/SanKen/rutorrent-titlebar.git
+ source = ratiocolor::git+https://github.com/senki/rutorrent-ratiocolor.git
source = extra::git+https://github.com/nelu/rutorrent-thirdparty-plugins.git
- md5sums = a3efa833b362ac7f3ff69ddaa720de81
+ source = MaterialDesign::git+https://github.com/Phlooo/ruTorrent-MaterialDesign.git
+ source = QuickBox::git+https://github.com/QuickBox/club-QuickBox.git
+ source = git+https://github.com/exetico/FlatUI.git
+ md5sums = 5c50a738ee4180d63b596519d07d64d5
md5sums = 3e0002fe9ce69f43513152c515944559
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = rutorrent-git
diff --git a/PKGBUILD b/PKGBUILD
index b1686397ab5c..5f666e996cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: skydrome <skydrome@i2pmail.org>
pkgname='rutorrent-git'
-pkgver=r1953.d40e7955
+pkgver=r1974.9191af0c
pkgrel=1
pkgdesc="Web frontend to rTorrent in PHP designed to resemble uTorrent"
url="https://github.com/Novik/ruTorrent"
@@ -32,18 +32,31 @@ _plugins=('extra/filemanager'
'extra/fileshare'
'extra/fileupload'
'extra/mediastream'
- 'titlebar')
+ 'titlebar'
+ 'ratiocolor')
+
+_themes=('MaterialDesign'
+ 'QuickBox'
+ 'FlatUI')
source=("plugins.ini"
"https://raw.githubusercontent.com/weixiyen/jquery-filedrop/master/jquery.filedrop.js"
"rutorrent::git+https://github.com/Novik/ruTorrent.git"
"titlebar::git+https://github.com/SanKen/rutorrent-titlebar.git"
- "extra::git+https://github.com/nelu/rutorrent-thirdparty-plugins.git")
+ "ratiocolor::git+https://github.com/senki/rutorrent-ratiocolor.git"
+ "extra::git+https://github.com/nelu/rutorrent-thirdparty-plugins.git"
+ "MaterialDesign::git+https://github.com/Phlooo/ruTorrent-MaterialDesign.git"
+ "QuickBox::git+https://github.com/QuickBox/club-QuickBox.git"
+ "git+https://github.com/exetico/FlatUI.git")
-md5sums=('a3efa833b362ac7f3ff69ddaa720de81'
+md5sums=('5c50a738ee4180d63b596519d07d64d5'
'3e0002fe9ce69f43513152c515944559'
'SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
pkgver() {
@@ -98,6 +111,11 @@ package() {
cp -r "$srcdir/$i" .
done
+ for i in ${_themes[@]}; do
+ rm -rf "$srcdir/$i/.git"
+ cp -r "$srcdir/$i" ./theme/themes
+ done
+
cp -f "$srcdir/jquery.filedrop.js" filedrop/jquery.filedrop.js
install -dm755 "$pkgdir/$_webdir"
diff --git a/plugins.ini b/plugins.ini
index 92e78b033d17..7dbdc2d9649e 100755
--- a/plugins.ini
+++ b/plugins.ini
@@ -86,6 +86,8 @@ enabled = user-defined
enabled = user-defined
[ratio]
enabled = user-defined
+[ratiocolor]
+enabled = user-defined
[rss]
enabled = user-defined
[seedingtime]