summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-06-01 15:29:29 -0400
committerskydrome2015-06-01 15:29:29 -0400
commitcbeb0b9c4e67d3df93fa1176672cbc5458252f49 (patch)
tree38b8171ac4c2257cb6061fb95b74c67c2f91a467
downloadaur-cbeb0b9c4e67d3df93fa1176672cbc5458252f49.tar.gz
Initial commit
-rw-r--r--.SRCINFO49
-rw-r--r--PKGBUILD98
-rwxr-xr-xplugins.ini144
-rw-r--r--rutorrent.install26
4 files changed, 317 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8f6f03163ee9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,49 @@
+pkgbase = rutorrent-git
+ pkgdesc = Web frontend to rTorrent in PHP designed to resemble uTorrent
+ pkgver = r1464.961d9bd
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/Novik/ruTorrent
+ install = rutorrent.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = subversion
+ depends = php
+ depends = curl
+ optdepends = mktorrent: create torrent files with mktorrent
+ optdepends = buildtorrent: create torrent files with buildtorrent
+ optdepends = transmission-cli: create torrent files with transmission
+ optdepends = php-geoip: enable geoip plugin
+ optdepends = geoip: enable geoip plugin
+ optdepends = unrar: enable unpack plugin
+ optdepends = unzip: enable unpack plugin
+ provides = rutorrent
+ provides = rutorrent-plugins
+ conflicts = rutorrent
+ conflicts = rutorrent-plugins
+ options = !strip
+ backup = usr/share/webapps/rutorrent/conf/config.php
+ backup = usr/share/webapps/rutorrent/conf/access.ini
+ backup = usr/share/webapps/rutorrent/conf/plugins.ini
+ source = plugins.ini
+ source = https://raw.githubusercontent.com/weixiyen/jquery-filedrop/master/jquery.filedrop.js
+ source = rutorrent::git+https://github.com/Novik/ruTorrent.git
+ source = titlebar::git+https://github.com/SanKen/rutorrent-titlebar.git
+ source = filemanager::svn+http://svn.rutorrent.org/svn/filemanager/trunk/filemanager
+ source = fileshare::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileshare
+ source = fileupload::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileupload
+ source = mediastream::svn+http://svn.rutorrent.org/svn/filemanager/trunk/mediastream
+ source = chat::svn+https://rutorrent-chat.googlecode.com/svn/trunk
+ md5sums = a3efa833b362ac7f3ff69ddaa720de81
+ md5sums = 020b0c3fc1220d490992473a75485add
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = rutorrent-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc798a567ebd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,98 @@
+# Maintainer: skydrome <skydrome@i2pmail.org>
+# Contributor: skydrome <skydrome@i2pmail.org>
+
+pkgname=('rutorrent-git')
+pkgver=r1464.961d9bd
+pkgrel=1
+epoch=1
+pkgdesc="Web frontend to rTorrent in PHP designed to resemble uTorrent"
+url="https://github.com/Novik/ruTorrent"
+license=('GPL')
+arch=('any')
+
+install=rutorrent.install
+options=(!strip)
+
+depends=('php' 'curl')
+makedepends=('git' 'subversion')
+optdepends=('mktorrent: create torrent files with mktorrent'
+ 'buildtorrent: create torrent files with buildtorrent'
+ 'transmission-cli: create torrent files with transmission'
+ 'php-geoip: enable geoip plugin'
+ 'geoip: enable geoip plugin'
+ 'unrar: enable unpack plugin'
+ 'unzip: enable unpack plugin')
+
+conflicts=('rutorrent' 'rutorrent-plugins')
+provides=('rutorrent' 'rutorrent-plugins')
+
+_webdir="usr/share/webapps"
+backup=("${_webdir}/rutorrent/conf/config.php"
+ "${_webdir}/rutorrent/conf/access.ini"
+ "${_webdir}/rutorrent/conf/plugins.ini")
+
+_plugins=('chat' 'filemanager' 'fileshare' 'fileupload' 'mediastream' 'titlebar')
+
+source=("plugins.ini"
+ "https://raw.githubusercontent.com/weixiyen/jquery-filedrop/master/jquery.filedrop.js"
+ "rutorrent::git+https://github.com/Novik/ruTorrent.git"
+ "titlebar::git+https://github.com/SanKen/rutorrent-titlebar.git"
+ "filemanager::svn+http://svn.rutorrent.org/svn/filemanager/trunk/filemanager"
+ "fileshare::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileshare"
+ "fileupload::svn+http://svn.rutorrent.org/svn/filemanager/trunk/fileupload"
+ "mediastream::svn+http://svn.rutorrent.org/svn/filemanager/trunk/mediastream"
+ "chat::svn+https://rutorrent-chat.googlecode.com/svn/trunk")
+
+md5sums=('a3efa833b362ac7f3ff69ddaa720de81'
+ '020b0c3fc1220d490992473a75485add'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$srcdir/rutorrent"
+
+ _gitrev=$(git rev-parse --short HEAD)
+ _gitcount=$(git rev-list --count HEAD)
+ echo "r${_gitcount}.${_gitrev}"
+}
+
+prepare() {
+ cd "$srcdir/rutorrent"
+
+ sed -i conf/config.php \
+ -e "s:\$topDirectory .*:\$topDirectory = '/home';:" \
+ -e "s:\$XMLRPCMountPoint .*:\$XMLRPCMountPoint = \"/rutorrent/RPC1\";:" \
+ -e "s:\$tempDirectory .*:\$tempDirectory = '/${_webdir}/rutorrent/tmp';:"
+ sed -i php/settings.php \
+ -e "s:'/tmp:'/${_webdir}/rutorrent/tmp/:"
+
+ _gitrev=$(git rev-parse --short HEAD)
+ _gitdate=$(git log -1 --format="%cd" --date=short)
+ _gitcount=$(git rev-list --count HEAD)
+
+ sed -i js/webui.js \
+ -e "s|version: \"3.*|version: \"3.x-git~${_gitrev} r${_gitcount} ${_gitdate}\",|"
+}
+
+package() {
+ cd "$srcdir/rutorrent/plugins"
+
+ for i in ${_plugins[@]}; do
+ cp -r "$srcdir/$i" .
+ done
+ cp -f "$srcdir/jquery.filedrop.js" filedrop/jquery.filedrop.js
+
+ install -dm755 "$pkgdir/$_webdir"
+ cd "$pkgdir/$_webdir"
+
+ cp -r "$srcdir/rutorrent" .
+ rm -r rutorrent/{.git*,README*}
+
+ install -Dm755 "$srcdir/plugins.ini" rutorrent/conf/plugins.ini
+ mkdir -p rutorrent/tmp
+}
diff --git a/plugins.ini b/plugins.ini
new file mode 100755
index 000000000000..92e78b033d17
--- /dev/null
+++ b/plugins.ini
@@ -0,0 +1,144 @@
+;; Plugins' permissions.
+;; If flag is not found in plugin section, corresponding flag from "default" section is used.
+;; If flag is not found in "default" section, it is assumed to be "yes".
+;;
+;; For setting individual plugin permissions you must write something like that:
+;;
+;; [ratio]
+;; enabled = yes ;; also may be "user-defined", in this case user can control plugin's state from UI
+;; canChangeToolbar = yes
+;; canChangeMenu = yes
+;; canChangeOptions = no
+;; canChangeTabs = yes
+;; canChangeColumns = yes
+;; canChangeStatusBar = yes
+;; canChangeCategory = yes
+;; canBeShutdowned = yes
+
+[default]
+enabled = user-defined
+canChangeToolbar = yes
+canChangeMenu = yes
+canChangeOptions = yes
+canChangeTabs = yes
+canChangeColumns = yes
+canChangeStatusBar = yes
+canChangeCategory = yes
+canBeShutdowned = yes
+
+
+;; Default
+
+[_getdir]
+enabled = yes
+[_noty2]
+enabled = yes
+[_task]
+enabled = yes
+[datadir]
+enabled = yes
+[erasedata]
+enabled = user-defined
+[httprpc]
+enabled = yes
+canBeShutdowned = no
+[show_peers_like_wtorrent]
+enabled = user-defined
+[theme]
+enabled = yes
+[tracklabels]
+enabled = user-defined
+
+
+;; Enabled
+
+[autotools]
+enabled = user-defined
+[check_port]
+enabled = user-defined
+[cookies]
+enabled = user-defined
+[cpuload]
+enabled = user-defined
+[create]
+enabled = user-defined
+[data]
+enabled = user-defined
+[diskspace]
+enabled = user-defined
+[edit]
+enabled = user-defined
+[extratio]
+enabled = user-defined
+[extsearch]
+enabled = user-defined
+[feeds]
+enabled = user-defined
+[fileshare]
+enabled = user-defined
+[fileupload]
+enabled = user-defined
+[filedrop]
+enabled = user-defined
+[filemanager]
+enabled = user-defined
+[geoip]
+enabled = user-defined
+[ratio]
+enabled = user-defined
+[rss]
+enabled = user-defined
+[seedingtime]
+enabled = user-defined
+[screenshots]
+enabled = user-defined
+[throttle]
+enabled = user-defined
+[titlebar]
+enabled = user-defined
+[trafic]
+enabled = user-defined
+[unpack]
+enabled = user-defined
+
+
+;; Disabled
+
+[_noty]
+enabled = no
+[chat]
+enabled = no
+[chunks]
+enabled = no
+[history]
+enabled = no
+[instantsearch]
+enabled = no
+[ipad]
+enabled = no
+[logoff]
+enabled = no
+[loginmgr]
+enabled = no
+[lookat]
+enabled = no
+[mediainfo]
+enabled = no
+[mediastream]
+enabled = no
+[nfo]
+enabled = no
+[retrackers]
+enabled = no
+[rpc]
+enabled = no
+[rssurlrewrite]
+enabled = no
+[rutracker_check]
+enabled = no
+[scheduler]
+enabled = no
+[source]
+enabled = no
+[spectrogram]
+enabled = no
diff --git a/rutorrent.install b/rutorrent.install
new file mode 100644
index 000000000000..b62915394370
--- /dev/null
+++ b/rutorrent.install
@@ -0,0 +1,26 @@
+APP_PATH="/usr/share/webapps/rutorrent"
+
+post_install() {
+ cat << EOF
+
+[Webserver Alias Examples]
+ Lighttpd: alias.url = ("/rutorrent/" => \""${APP_PATH}/"\")
+ Apache: Alias /rutorrent/ /usr/share/webapps/rutorrent/
+ Hiawatha: Alias = /rutorrent:/usr/share/webapps/rutorrent
+ Nginx: ln -s /usr/share/webapps/rutorrent /srv/http/rutorrent
+
+EOF
+
+post_upgrade
+}
+
+post_upgrade() {
+
+ chown -R http:http "${APP_PATH}"
+ chmod -R 755 "${APP_PATH}"
+ cd "$APP_PATH"
+
+ chmod 750 {conf,share/{users,settings}}
+ chmod 777 {tmp,share/torrents}
+ chmod 640 {.htaccess,share/.htaccess}
+}