summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHuki2021-10-03 09:44:35 +0530
committerHuki2021-10-03 09:44:35 +0530
commit1eb5f6a87ec98467078b5134f6cae0c902072cf2 (patch)
tree2e43eac190345dc59dcd20f35c0d8795f19da017
parent4010bc5945befb3696bc00f0932b8ef135bd189e (diff)
downloadaur-1eb5f6a87ec98467078b5134f6cae0c902072cf2.tar.gz
support multi-arch build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90e655aa9157..c52d677bcceb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,7 +3,10 @@ pkgbase = rvgl-bin
pkgver = 21.0930a
pkgrel = 1
url = https://rvgl.re-volt.io
+ arch = i686
arch = x86_64
+ arch = armv7h
+ arch = aarch64
groups = rvgl-basic
groups = rvgl-original
groups = rvgl-community
diff --git a/PKGBUILD b/PKGBUILD
index e69d2523d44d..e38cbebf64d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _gamefilesver=18.0328
pkgrel=1
pkgdesc="Rewrite of Re-Volt, popular R/C car racing game from 1999."
url='https://rvgl.re-volt.io'
-arch=('x86_64')
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
license=('custom')
depends=('sdl2' 'sdl2_image' 'openal' 'enet' 'libunistring')
optdepends=('rvgl-dcpack: dreamcast content pack'
@@ -28,6 +28,12 @@ sha256sums=('SKIP'
'SKIP'
'4313552a067486339319e6e4b13386040183e196d7b6e26a1fec56a711e4721d')
+_binsuffix='none'
+[ "$CARCH" = 'i686' ] && _binsuffix='32'
+[ "$CARCH" = 'x86_64' ] && _binsuffix='64'
+[ "$CARCH" = 'armv7h' ] && _binsuffix='armhf'
+[ "$CARCH" = 'aarch64' ] && _binsuffix='arm64'
+
package() {
# Core game files
cd "$srcdir/rvgl_game_files"
@@ -49,9 +55,9 @@ package() {
# Platform binaries
cd "$srcdir/rvgl_platform/linux"
- install -Dm755 rvgl.64 "$pkgdir/opt/rvgl/rvgl"
+ install -Dm755 "rvgl.$_binsuffix" "$pkgdir/opt/rvgl/rvgl"
# Launcher
cd "$srcdir"
- install -Dm755 RVGL.desktop "$pkgdir/usr/share/applications/RVGL.desktop"
+ install -Dm755 "RVGL.desktop" "$pkgdir/usr/share/applications/RVGL.desktop"
}