summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhuki2020-05-22 15:27:41 +0530
committerhuki2020-05-22 15:27:41 +0530
commitde127ec5a9638e614739948a44a0d1a4b378fa4f (patch)
tree896253e0bdb91982f5d3c7c9a94ec9de625fedf0
downloadaur-de127ec5a9638e614739948a44a0d1a4b378fa4f.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd6b8782c9f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = rvgl-io-clockworks
+ pkgdesc = Additional classic clockwork cars for RVGL.
+ pkgver = 18.0415
+ pkgrel = 1
+ url = https://rvgl.re-volt.io
+ arch = any
+ groups = rvgl-community
+ license = custom
+ makedepends = git
+ depends = rvgl-bin
+ source = rvgl_io_clockworks::git+https://gitlab.com/re-volt/rvio/clockworks_classic.git#tag=18.0415
+ sha256sums = SKIP
+
+pkgname = rvgl-io-clockworks
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d80d7ed818d2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg*
+src*
+*pkg*
+rvgl_*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e5aa9e92159
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Huki <gk7huki@gmail.com>
+# Contributor: Svitozar Cherepii <razotivs@gmail.com>
+
+pkgname=rvgl-io-clockworks
+pkgver=18.0415
+pkgrel=1
+pkgdesc="Additional classic clockwork cars for RVGL."
+url='https://rvgl.re-volt.io'
+arch=('any')
+license=('custom')
+depends=('rvgl-bin')
+makedepends=('git')
+groups=('rvgl-community')
+source=("rvgl_io_clockworks"::git+https://gitlab.com/re-volt/rvio/clockworks_classic.git#tag=${pkgver})
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/rvgl_io_clockworks"
+ find * -type f -exec install -Dm644 {} "$pkgdir/opt/rvgl/{}" \;
+}