summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTianyu Liu2015-06-24 23:49:24 -0400
committerTianyu Liu2015-06-24 23:49:24 -0400
commit371d09ac95f83fb4d55740c215c02e1152ff85dd (patch)
tree06c8210d451889e3137f0fa78a74e4fb1521b56d
downloadaur-371d09ac95f83fb4d55740c215c02e1152ff85dd.tar.gz
Initial Upload
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD29
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db2f9958ac16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = rwhoisd
+ pkgdesc = RWhois (Referral Whois) is a Directory Services protocol which extends and enhances the Whois concept in a hierarchical and scalable fashion.
+ pkgver = 1.5.9.6
+ pkgrel = 1
+ url = http://projects.arin.net/rwhois/
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ source = http://projects.arin.net/rwhois/ftp/rwhoisd-1.5.9.6.tar.gz
+ sha256sums = 66793f02bc9370914ca3f579409e8f79b6a394b8a981168ead7b1a6654a83a2a
+
+pkgname = rwhoisd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45a75e92725e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tianyu Liu <lty1993[at]lty[dot]me>
+pkgname=rwhoisd
+pkgver=1.5.9.6
+pkgrel=1
+pkgdesc="RWhois (Referral Whois) is a Directory Services protocol which extends and enhances the Whois concept in a hierarchical and scalable fashion."
+url="http://projects.arin.net/rwhois/"
+arch=('x86_64' 'i686')
+license=('GPLv2')
+depends=()
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("http://projects.arin.net/rwhois/ftp/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('66793f02bc9370914ca3f579409e8f79b6a394b8a981168ead7b1a6654a83a2a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --bindir=/usr/bin --sbindir=/usr/bin --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: