summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAles Katona2019-08-25 09:52:11 -0600
committerAles Katona2019-08-25 09:52:11 -0600
commite85e3a0d8c48bc02c87f11d20d5315c3353af7dc (patch)
tree61d57562e883b84b65b7c26656549217bfc1a90a
downloadaur-e85e3a0d8c48bc02c87f11d20d5315c3353af7dc.tar.gz
add rx pixel editor to AUR
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--init.tx.patch13
-rw-r--r--sweetie16.palette22
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14ac39f5ddf8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rx
+ pkgdesc = A modern and extensible pixel editor implemented in rust.
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://cloudhead.io/rx/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = clang
+ makedepends = rust
+ source = https://github.com/cloudhead/rx/archive/v0.1.0.tar.gz
+ source = http://cloudhead.io/rx/palettes/sweetie16.palette
+ sha256sums = b5b413d7a4bb3921f6a471dcc0767eee31275ede548ccc59216231c8b2702b26
+ sha256sums = 17f4f037dbcedbed12c650a68cf2af372fdcd4541a2b23ae40d378d12d491ff4
+
+pkgname = rx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9b2122870b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Ales Katona <almindor@gmail.com>
+pkgname=rx
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A modern and extensible pixel editor implemented in rust.'
+arch=(i686 x86_64)
+url='http://cloudhead.io/rx/'
+license=('GPL3')
+makedepends=('clang' 'rust')
+source=("https://github.com/cloudhead/rx/archive/v${pkgver}.tar.gz"
+ 'http://cloudhead.io/rx/palettes/sweetie16.palette')
+sha256sums=('b5b413d7a4bb3921f6a471dcc0767eee31275ede548ccc59216231c8b2702b26'
+ '17f4f037dbcedbed12c650a68cf2af372fdcd4541a2b23ae40d378d12d491ff4')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ patch -p0 < ../../init.tx.patch
+ cargo build --release --features vulkan
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/rx/palettes"
+
+ install -Dm755 -t "${pkgdir}/usr/bin" "${srcdir}/${pkgname}-${pkgver}/target/release/rx"
+ install -Dm644 -t "${pkgdir}/usr/share/rx/palettes" "sweetie16.palette"
+}
diff --git a/init.tx.patch b/init.tx.patch
new file mode 100644
index 000000000000..66ff71b52aa7
--- /dev/null
+++ b/init.tx.patch
@@ -0,0 +1,13 @@
+diff --git config/init.rx config/init.rx
+index f58c0bb..7389856 100644
+--- config/init.rx
++++ config/init.rx
+@@ -27,7 +27,7 @@ map <left> :pan -1 0 -- Pan view left
+ map <right> :pan 1 0 -- Pan view right
+ map <return> :f/new -- Create new frame
+
+-source palettes/sweetie16.palette -- Source a color palette
++source /usr/share/rx/palettes/sweetie16.palette -- Source a color palette
+
+ set vsync = off -- Turn off Vsync
+ set frame_delay = 8.0 -- Set frame delay to 8 milliseconds
diff --git a/sweetie16.palette b/sweetie16.palette
new file mode 100644
index 000000000000..47b1b266b67c
--- /dev/null
+++ b/sweetie16.palette
@@ -0,0 +1,22 @@
+-----------------
+-- SWEETIE 16 --
+-- by GrafxKid --
+-----------------
+
+p/clear
+#1a1c2c
+#5d275d
+#b13e53
+#ef7d57
+#ffcd75
+#a7f070
+#38b764
+#257179
+#29366f
+#3b5dc9
+#41a6f6
+#73eff7
+#f4f4f4
+#94b0c2
+#566c86
+#333c57