summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDmytro Meleshko2020-01-02 11:29:03 +0200
committerDmytro Meleshko2020-01-02 11:29:03 +0200
commitfe2ed15e6d2db717c2b541efd7f16eef0049d085 (patch)
treef06f4ce87933256e4a803cdb2ad35afe3dc12439
parent7e782dbe192127f9894ba842362855d460a83d78 (diff)
downloadaur-fe2ed15e6d2db717c2b541efd7f16eef0049d085.tar.gz
v0.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0f0abeb4ffa..d5278cb4271b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rx-bin
pkgdesc = A modern and extensible pixel editor implemented in Rust (this package downloads and extracts the official AppImage)
- pkgver = 0.2.0
+ pkgver = 0.3.0
pkgrel = 1
url = https://cloudhead.io/rx/
arch = x86_64
@@ -9,10 +9,10 @@ pkgbase = rx-bin
depends = gcc-libs
provides = rx
conflicts = rx
- noextract = rx-0.2.0-x86_64-unknown-linux-gnu.AppImage
+ noextract = rx-0.3.0-x86_64.AppImage
options = !strip
- source = https://github.com/cloudhead/rx/releases/download/v0.2.0/rx-0.2.0-x86_64-unknown-linux-gnu.AppImage
- sha256sums = bbbd51a3eade9966b768480da4e92680e12bb979f47cc5d61aff460474ee8b6a
+ source = https://github.com/cloudhead/rx/releases/download/v0.3.0/rx-0.3.0-x86_64.AppImage
+ sha256sums = c32bd63f33809a84547937dfc6b68c0f321050d8283659155964e469733c5bb6
pkgname = rx-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6cc1230262b4..f013c3eb22c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dmytro Meleshko <dmytro.meleshko@gmail.com>
_pkgname=rx
pkgname=${_pkgname}-bin
-pkgver=0.2.0
+pkgver=0.3.0
pkgrel=1
pkgdesc="A modern and extensible pixel editor implemented in Rust (this package downloads and extracts the official AppImage)"
arch=("x86_64")
@@ -11,10 +11,10 @@ depends=("libx11" "gcc-libs")
provides=(${_pkgname})
conflicts=(${_pkgname})
options=(!strip)
-_appimage_file="$_pkgname-$pkgver-$CARCH-unknown-linux-gnu.AppImage"
+_appimage_file="$_pkgname-$pkgver-$CARCH.AppImage"
source=("https://github.com/cloudhead/rx/releases/download/v$pkgver/$_appimage_file")
noextract=("$_appimage_file")
-sha256sums=('bbbd51a3eade9966b768480da4e92680e12bb979f47cc5d61aff460474ee8b6a')
+sha256sums=('c32bd63f33809a84547937dfc6b68c0f321050d8283659155964e469733c5bb6')
build() {
chmod +x "$_appimage_file"
@@ -27,5 +27,5 @@ package() {
cd "$pkgname-$pkgver/squashfs-root"
install -Dm755 "usr/bin/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
install -Dm644 "usr/share/applications/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
- install -Dm644 "usr/share/icons/hicolor/128x128/apps/$_pkgname.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
+ install -Dm644 "usr/share/icons/hicolor/64x64/apps/$_pkgname.png" "$pkgdir/usr/share/pixmaps/$_pkgname.png"
}