summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Brunel2015-01-01 13:48:26 +0100
committerOlivier Brunel2015-06-08 19:16:31 +0200
commit113d3b333365d053cba9cd1d447c6f6b0befdb1a (patch)
tree0824243dd4a701228bdc01f918ac9424ba85620e
parent801aaa9982c44ea592d5403c251cf3d5188d3062 (diff)
downloadaur-113d3b333365d053cba9cd1d447c6f6b0befdb1a.tar.gz
rxvt-unicode-better-wheel-scrolling: upgrade to 9.21
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD16
-rw-r--r--clear.patch10
-rw-r--r--secondaryWheel.patch22
4 files changed, 33 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0ca1b4786a6..2998f1e501d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rxvt-unicode-better-wheel-scrolling
pkgdesc = An unicode enabled rxvt-clone terminal emulator (urxvt) w/ better wheel scrolling (VTE-like) (& no utmp/wtmp support)
- pkgver = 9.20
- pkgrel = 3
+ pkgver = 9.21
+ pkgrel = 1
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
@@ -13,18 +13,18 @@ pkgbase = rxvt-unicode-better-wheel-scrolling
optdepends = perl: lots of utilities
provides = rxvt-unicode
conflicts = rxvt-unicode
- source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.20.tar.bz2
+ source = http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-9.21.tar.bz2
source = rxvt-unicode.desktop
source = clear.patch
source = secondaryWheel.patch
- md5sums = 4a5b823f08d21036f94a6c51e94d025b
+ md5sums = a9a06c608258c5fd247c3725d8f44582
md5sums = af8e6ad4cd2d33c26f8df6a838685332
- md5sums = b7ec32358445a1037d447cb0f08506b5
- md5sums = 6e137593a69b4b584305f3d513e471bf
- sha1sums = 6214c7893a8c968936103e255a1d3d1e9868abf9
+ md5sums = edeed8f00d5917bc002b2e10ba7e900c
+ md5sums = c73b3a470a02da0bf19ad6e9b83d0696
+ sha1sums = 33297e5303e45d27e07f40060d3655ae019eefdc
sha1sums = 9a31b46324c0be44fb97be0828e1ead2311b3f9f
- sha1sums = 83f4ac268af5e2b5542721f3a82695f0da36c66f
- sha1sums = 04711ddd928862251d50ec3565750bdf4a3e2a07
+ sha1sums = fc77f75bd2d51baa4abef81983dab044d7f498ce
+ sha1sums = e50503f786deb6d6c2b6b8bcf486bf509c14af71
pkgname = rxvt-unicode-better-wheel-scrolling
diff --git a/PKGBUILD b/PKGBUILD
index 193a92947f7e..36ff1f01f0a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
_pkgname=rxvt-unicode
pkgname=${_pkgname}-better-wheel-scrolling
-pkgver=9.20
-pkgrel=3
+pkgver=9.21
+pkgrel=1
pkgdesc="An unicode enabled rxvt-clone terminal emulator (urxvt) w/ better wheel scrolling (VTE-like) (& no utmp/wtmp support)"
arch=('i686' 'x86_64')
url="http://software.schmorp.de/pkg/rxvt-unicode.html"
@@ -20,14 +20,14 @@ conflicts=($_pkgname)
source=(http://dist.schmorp.de/rxvt-unicode/${_pkgname}-${pkgver}.tar.bz2 \
${_pkgname}.desktop
clear.patch secondaryWheel.patch)
-md5sums=('4a5b823f08d21036f94a6c51e94d025b'
+md5sums=('a9a06c608258c5fd247c3725d8f44582'
'af8e6ad4cd2d33c26f8df6a838685332'
- 'b7ec32358445a1037d447cb0f08506b5'
- '6e137593a69b4b584305f3d513e471bf')
-sha1sums=('6214c7893a8c968936103e255a1d3d1e9868abf9'
+ 'edeed8f00d5917bc002b2e10ba7e900c'
+ 'c73b3a470a02da0bf19ad6e9b83d0696')
+sha1sums=('33297e5303e45d27e07f40060d3655ae019eefdc'
'9a31b46324c0be44fb97be0828e1ead2311b3f9f'
- '83f4ac268af5e2b5542721f3a82695f0da36c66f'
- '04711ddd928862251d50ec3565750bdf4a3e2a07')
+ 'fc77f75bd2d51baa4abef81983dab044d7f498ce'
+ 'e50503f786deb6d6c2b6b8bcf486bf509c14af71')
prepare() {
cd "${srcdir}/${_pkgname}-${pkgver}"
diff --git a/clear.patch b/clear.patch
index f9036b2a0d41..69167d0f3438 100644
--- a/clear.patch
+++ b/clear.patch
@@ -1,8 +1,8 @@
diff --git a/src/command.C b/src/command.C
-index 153f0e1..24c7ad0 100644
+index d212764..b1a5ab1 100644
--- a/src/command.C
+++ b/src/command.C
-@@ -2922,6 +2922,10 @@ rxvt_term::process_csi_seq ()
+@@ -2913,6 +2913,10 @@ rxvt_term::process_csi_seq ()
return;
}
@@ -13,7 +13,7 @@ index 153f0e1..24c7ad0 100644
switch (ch)
{
/*
-@@ -2985,6 +2989,12 @@ rxvt_term::process_csi_seq ()
+@@ -2976,6 +2980,12 @@ rxvt_term::process_csi_seq ()
case CSI_CUP: /* 8.3.21: (1,1) CURSOR POSITION */
case CSI_HVP: /* 8.3.64: (1,1) CHARACTER AND LINE POSITION */
@@ -26,7 +26,7 @@ index 153f0e1..24c7ad0 100644
scr_gotorc (arg[0] - 1, nargs < 2 ? 0 : (arg[1] - 1), 0);
break;
-@@ -2996,6 +3006,16 @@ rxvt_term::process_csi_seq ()
+@@ -2987,6 +2997,16 @@ rxvt_term::process_csi_seq ()
break;
case CSI_ED: /* 8.3.40: (0) ERASE IN PAGE */
@@ -43,7 +43,7 @@ index 153f0e1..24c7ad0 100644
scr_erase_screen (arg[0]);
break;
-@@ -3144,6 +3164,16 @@ rxvt_term::process_csi_seq ()
+@@ -3135,6 +3155,16 @@ rxvt_term::process_csi_seq ()
default:
break;
}
diff --git a/secondaryWheel.patch b/secondaryWheel.patch
index 3bb71b8557fb..ebb0e1af41bd 100644
--- a/secondaryWheel.patch
+++ b/secondaryWheel.patch
@@ -1,8 +1,8 @@
diff --git a/doc/rxvt.1.pod b/doc/rxvt.1.pod
-index 87042cd..9dfb861 100644
+index 169e104..4bb13b3 100644
--- a/doc/rxvt.1.pod
+++ b/doc/rxvt.1.pod
-@@ -417,6 +417,11 @@ B<secondaryScreen>.
+@@ -427,6 +427,11 @@ B<secondaryScreen>.
Turn on/off secondary screen scroll (default enabled); resource
B<secondaryScroll>.
@@ -14,7 +14,7 @@ index 87042cd..9dfb861 100644
=item B<-hold>|B<+hold>
Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
-@@ -1029,6 +1034,13 @@ option is enabled, scrolls on the secondary screen will change the
+@@ -1044,6 +1049,13 @@ option is enabled, scrolls on the secondary screen will change the
scrollback buffer and, when secondaryScreen is off, switching
to/from the secondary screen will instead scroll the screen up.
@@ -29,10 +29,10 @@ index 87042cd..9dfb861 100644
Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
diff --git a/src/command.C b/src/command.C
-index 153f0e1..df22652 100644
+index d212764..3b7e266 100644
--- a/src/command.C
+++ b/src/command.C
-@@ -2246,10 +2246,46 @@ rxvt_term::button_release (XButtonEvent &ev)
+@@ -2237,10 +2237,46 @@ rxvt_term::button_release (XButtonEvent &ev)
}
else
# endif
@@ -82,10 +82,10 @@ index 153f0e1..df22652 100644
break;
#endif
diff --git a/src/optinc.h b/src/optinc.h
-index d814035..a365037 100644
+index 09f9a26..c79a5be 100644
--- a/src/optinc.h
+++ b/src/optinc.h
-@@ -26,6 +26,7 @@
+@@ -27,6 +27,7 @@
def(cursorBlink)
def(secondaryScreen)
def(secondaryScroll)
@@ -94,10 +94,10 @@ index d814035..a365037 100644
def(cursorUnderline)
#if ENABLE_FRILLS
diff --git a/src/rsinc.h b/src/rsinc.h
-index 1483955..10f6642 100644
+index 682322c..6325057 100644
--- a/src/rsinc.h
+++ b/src/rsinc.h
-@@ -103,6 +103,7 @@
+@@ -104,6 +104,7 @@
#ifndef NO_SECONDARY_SCREEN
def (secondaryScreen)
def (secondaryScroll)
@@ -106,10 +106,10 @@ index 1483955..10f6642 100644
#if OFF_FOCUS_FADING
def (fade)
diff --git a/src/xdefaults.C b/src/xdefaults.C
-index 69acdd8..3e858de 100644
+index 2308844..0f5d2d0 100644
--- a/src/xdefaults.C
+++ b/src/xdefaults.C
-@@ -262,6 +262,7 @@ optList[] = {
+@@ -264,6 +264,7 @@ optList[] = {
#ifndef NO_SECONDARY_SCREEN
BOOL (Rs_secondaryScreen, "secondaryScreen", "ssc", Opt_secondaryScreen, 0, "enable secondary screen"),
BOOL (Rs_secondaryScroll, "secondaryScroll", "ssr", Opt_secondaryScroll, 0, "enable secondary screen scroll"),