summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdriaan Zonnenberg2016-09-18 16:45:30 +0200
committerAdriaan Zonnenberg2016-09-18 16:45:30 +0200
commit35ed71937144c9eeaad0b71635fbf5f5ea10755a (patch)
treef5bcfe784239a51ec4b9a16488ef6939239bde98
downloadaur-35ed71937144c9eeaad0b71635fbf5f5ea10755a.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD84
-rw-r--r--urxvt-tabbed.desktop10
-rw-r--r--urxvt.desktop10
-rw-r--r--urxvtc.desktop10
6 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..618e6f82ae68
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = rxvt-unicode-cvs
+ pkgdesc = A unicode enabled rxvt-clone terminal emulator (urxvt) - latest cvs revision
+ pkgver = 20160726
+ pkgrel = 1
+ url = http://software.schmorp.de/pkg/rxvt-unicode.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cvs
+ depends = libxft
+ depends = perl
+ depends = startup-notification
+ depends = rxvt-unicode-terminfo
+ optdepends = gtk2-perl: to use the urxvt-tabbed
+ provides = rxvt-unicode
+ conflicts = rxvt-unicode
+ source = urxvt.desktop
+ source = urxvtc.desktop
+ source = urxvt-tabbed.desktop
+ sha1sums = b5a4507f85ebb7bac589db2e07d9bc40106720d9
+ sha1sums = 62c4ffecfce6967def394dd4d418b68652372ea2
+ sha1sums = cd204d608d114d39c80331efe0af0231ad6b7e18
+
+pkgname = rxvt-unicode-cvs
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d284f9aeda40
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/src
+/pkg
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad85b31f70af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# Maintainer: Adriaan Zonnenberg <amz@adriaan.xyz>
+# Contributor: Florian Bruhin (The-Compiler) <archlinux.org@the-compiler.org>
+# Contributor: Daniel Micay <danielmicay@gmail.com>
+# Contributor: Sébastien Luttringer
+# Contributor: Angel Velasquez <angvp@archlinux.org>
+# Contributor: tobias <tobias@archlinux.org>
+# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
+
+_pkgname=rxvt-unicode
+pkgname=rxvt-unicode-cvs
+pkgver=20160726
+pkgrel=1
+pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt) - latest cvs revision'
+arch=('i686' 'x86_64')
+url='http://software.schmorp.de/pkg/rxvt-unicode.html'
+license=('GPL')
+depends=('libxft' 'perl' 'startup-notification' 'rxvt-unicode-terminfo')
+makedepends=('cvs')
+optdepends=('gtk2-perl: to use the urxvt-tabbed')
+provides=(rxvt-unicode)
+conflicts=(rxvt-unicode)
+source=('urxvt.desktop'
+ 'urxvtc.desktop'
+ 'urxvt-tabbed.desktop')
+sha1sums=('b5a4507f85ebb7bac589db2e07d9bc40106720d9'
+ '62c4ffecfce6967def394dd4d418b68652372ea2'
+ 'cd204d608d114d39c80331efe0af0231ad6b7e18')
+
+prepare() {
+ cd ${srcdir}
+ cvs -z3 -d :pserver:anonymous@cvs.schmorp.de/schmorpforge co ${_pkgname}
+}
+
+build() {
+ cd ${srcdir}/${_pkgname}
+ # we disable smart-resize (FS#34807)
+ # do not specify --with-terminfo (FS#46424)
+ ./configure \
+ --prefix=/usr \
+ --enable-256-color \
+ --enable-combining \
+ --enable-fading \
+ --enable-font-styles \
+ --enable-iso14755 \
+ --enable-keepscrolling \
+ --enable-lastlog \
+ --enable-mousewheel \
+ --enable-next-scroll \
+ --enable-perl \
+ --enable-pointer-blank \
+ --enable-rxvt-scroll \
+ --enable-selectionscrolling \
+ --enable-slipwheeling \
+ --disable-smart-resize \
+ --enable-startup-notification \
+ --enable-transparency \
+ --enable-unicode3 \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-xft \
+ --enable-xim \
+ --enable-xterm-scroll \
+ --disable-frills
+ make
+}
+
+package() {
+
+ # install freedesktop menu
+ for _f in urxvt urxvtc urxvt-tabbed; do
+ install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ done
+
+ cd $_pkgname
+
+ # workaround terminfo installation
+ export TERMINFO="$srcdir/terminfo"
+ install -d "$TERMINFO"
+ make DESTDIR="$pkgdir" install
+
+ # install the tabbing wrapper ( requires gtk2-perl! )
+ sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
+ install -Dm 755 doc/rxvt-tabbed "$pkgdir/usr/bin/urxvt-tabbed"
+}
diff --git a/urxvt-tabbed.desktop b/urxvt-tabbed.desktop
new file mode 100644
index 000000000000..f3efdc9b9e37
--- /dev/null
+++ b/urxvt-tabbed.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=urxvt (tabbed)
+Comment=An unicode capable and tabbed rxvt clone
+Exec=urxvt-tabbed
+Icon=terminal
+Terminal=false
+Type=Application
+Categories=Application;System;TerminalEmulator;
diff --git a/urxvt.desktop b/urxvt.desktop
new file mode 100644
index 000000000000..0a9baf7dfcce
--- /dev/null
+++ b/urxvt.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=urxvt
+Comment=An unicode capable rxvt clone
+Exec=urxvt
+Icon=terminal
+Terminal=false
+Type=Application
+Categories=Application;System;TerminalEmulator;
diff --git a/urxvtc.desktop b/urxvtc.desktop
new file mode 100644
index 000000000000..e39a418f6522
--- /dev/null
+++ b/urxvtc.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Encoding=UTF-8
+Name=urxvt (client)
+Comment=An unicode capable rxvt clone client for urxvtd
+Exec=urxvtc
+Icon=terminal
+Terminal=false
+Type=Application
+Categories=Application;System;TerminalEmulator;