aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Hahler2017-05-06 08:06:56 +0200
committerDaniel Hahler2017-05-06 08:06:56 +0200
commit116e807e27778ea1c0cee825ec1f412896e596dc (patch)
treee0877e885489a4ebc8d2d99b93bd92fd0c322bf0
parent72ff42787b37bd786a4290b8adfada8e66c8e2c7 (diff)
downloadaur-116e807e27778ea1c0cee825ec1f412896e596dc.tar.gz
--enable-wide-glyphs, remove obsolete patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--fix-smart-resize-with-x11-frame-borders.patch54
3 files changed, 3 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 589f1bfe296f..5a296503ab3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rxvt-unicode-cvs-patched-wideglyphs
pkgdesc = Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing and wide glyphs patch (cvs version)
pkgver = 20170412
- pkgrel = 1
+ pkgrel = 2
url = http://software.schmorp.de/pkg/rxvt-unicode.html
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 02b0d44ff820..520d27fdc977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-cvs-patched-wideglyphs
pkgver=20170412
-pkgrel=1
+pkgrel=2
pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing and wide glyphs patch (cvs version)'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
@@ -70,6 +70,7 @@ build() {
--enable-transparency \
--enable-unicode3 \
--enable-utmp \
+ --enable-wide-glyphs \
--enable-wtmp \
--enable-xft \
--enable-xim \
diff --git a/fix-smart-resize-with-x11-frame-borders.patch b/fix-smart-resize-with-x11-frame-borders.patch
deleted file mode 100644
index 9311f9d70d8d..000000000000
--- a/fix-smart-resize-with-x11-frame-borders.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-commit bec3f19
-Author: Emanuele Giaquinta <e.giaquinta@glauco.it>
-Date: Tue Jun 28 21:56:17 2016 +0000
-
- Fix invalid moves when smart resize is enabled and the wm uses X11 borders for the frame windows.
-
- Patch by Uli Schlachter.
----
- src/main.C | 25 +++++++++++++++++++++++--
- 1 file changed, 23 insertions(+), 2 deletions(-)
-
-diff --git a/src/main.C b/src/main.C
-index 39aa5ec..5fa605e 100644
---- a/src/main.C
-+++ b/src/main.C
-@@ -1054,6 +1054,25 @@ rxvt_term::alias_color (int dst, int src)
- pix_colors[dst].set (this, rs[Rs_color + dst] = rs[Rs_color + src]);
- }
-
-+#ifdef SMART_RESIZE
-+static unsigned int
-+get_parent_bw (Display *dpy, Window w)
-+{
-+ int idummy;
-+ unsigned int udummy;
-+ Window wdummy, parent;
-+ Window *children;
-+ unsigned int nchildren, border_width;
-+
-+ XQueryTree (dpy, w, &wdummy, &parent, &children, &nchildren);
-+ XFree (children);
-+ XGetGeometry (dpy, parent, &wdummy, &idummy, &idummy,
-+ &udummy, &udummy, &border_width, &udummy);
-+
-+ return border_width;
-+}
-+#endif
-+
- /* -------------------------------------------------------------------- *
- * - WINDOW RESIZING - *
- * -------------------------------------------------------------------- */
-@@ -1098,8 +1117,10 @@ rxvt_term::resize_all_windows (unsigned int newwidth, unsigned int newheight, in
- */
- if (x1 != x || y1 != y)
- {
-- x -= x1;
-- y -= y1;
-+ unsigned int border_width = get_parent_bw (dpy, parent);
-+
-+ x -= x1 + border_width;
-+ y -= y1 + border_width;
- }
-
- x1 = (DisplayWidth (dpy, display->screen) - old_width ) / 2;