summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlanc2019-02-19 01:51:57 +0100
committerKlanc2019-02-19 01:51:57 +0100
commit3efd1e64634678421df57322b915f4f06fb65a59 (patch)
treeeeb2dfdc22d4678597bae0c43234b1d0f66daa52
parentd506bf84c2f78d9cbdb7c2209b4401d9a5dd9984 (diff)
downloadaur-3efd1e64634678421df57322b915f4f06fb65a59.tar.gz
Added wcwidth patch from blueyed's package
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a93c825f432c..71c5e14caed1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,38 +5,46 @@
# Contributor: Angel Velasquez <angvp@archlinux.org>
# Contributor: tobias <tobias@archlinux.org>
# Contributor: dibblethewrecker dibblethewrecker.at.jiwe.dot.org
-# Contributor: klanc <lewis at ledgedash dot com>
-
+# Contributor: Daniel Hahler <archlinux+aur@thequod.de>
_pkgname=rxvt-unicode
pkgname=rxvt-unicode-fa-patched
-pkgver=20190218
+pkgver=20190219
pkgrel=1
-pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt) - Patched to allow FontAwesome fonts'
+pkgdesc='A unicode enabled rxvt-clone terminal emulator (urxvt) - Patched to enable FontAwesome support + wcwidth'
arch=('i686' 'x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
license=('GPL')
depends=('libxft' 'perl' 'startup-notification' 'rxvt-unicode-terminfo')
-makedepends=('git' 'cvs')
+makedepends=('cvs')
optdepends=('gtk2-perl: to use the urxvt-tabbed')
provides=(rxvt-unicode)
conflicts=(rxvt-unicode)
source=('urxvt.desktop'
'urxvtc.desktop'
- 'urxvt-tabbed.desktop')
+ 'urxvt-tabbed.desktop'
+ 'FontAwesome.patch'
+ 'line-spacing-fix.patch'
+ 'wcwidthcallback.patch')
sha1sums=('b5a4507f85ebb7bac589db2e07d9bc40106720d9'
'62c4ffecfce6967def394dd4d418b68652372ea2'
- 'cd204d608d114d39c80331efe0af0231ad6b7e18')
+ 'cd204d608d114d39c80331efe0af0231ad6b7e18'
+ '9575c7a83817a7b347b3d739b4b55f9ed8a77859'
+ 'b7fde1c46af45e831828738874f14b092b1e795f'
+ 'c884f2be45073624c7f34ed6011e0a7dad3ffb22')
prepare() {
cd ${srcdir}
cvs -z3 -d :pserver:anonymous@cvs.schmorp.de/schmorpforge co ${_pkgname}
- mv ${_pkgname} cvsTemp
- git clone https://github.com/theKlanc/rxvt-unicode-fa-patched.git ${_pkgname}
- cp -r cvsTemp/libecb ${_pkgname}
- cp -r cvsTemp/libev ${_pkgname}
- cp -r cvsTemp/libptytty ${_pkgname}
- rm -rf cvsTemp
+ cd ${_pkgname}
+ echo "applying line-spacing-fix.patch"
+ patch -p0 -i ../../line-spacing-fix.patch
+ echo "applying FontAwesome.patch"
+ patch -p1 -i ../../FontAwesome.patch
+ rm -f src/rxvtwcwidth.C src/rxvtwcwidth.h README.md
+ echo "Applying wcwidthcallback.patch"
+ patch -Np1 -i ../../wcwidthcallback.patch
+
}
build() {
@@ -68,7 +76,8 @@ build() {
--enable-xft \
--enable-xim \
--enable-xterm-scroll \
- --disable-frills
+ --disable-frills \
+ --enable-wcwidthpreload
make
}