summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsmo Toijala2023-08-10 17:33:34 +0300
committerIsmo Toijala2023-08-10 17:33:34 +0300
commitf519e27cee9324a9fc90dcbcf6ce71251b3114bd (patch)
treeca639450d3e1693af1159083cc9e066ef2dfe568
parent03af61667e729f5707f4c2969b440f9e78b1a927 (diff)
downloadaur-f519e27cee9324a9fc90dcbcf6ce71251b3114bd.tar.gz
update to 9.31
-rw-r--r--PKGBUILD88
-rw-r--r--clear.patch15
-rw-r--r--font-width-fix.patch14
-rw-r--r--line-spacing-fix.patch16
-rw-r--r--secondaryWheel.patch30
5 files changed, 95 insertions, 68 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e0a5e31b624..89ad35fa39c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,6 @@
# Maintainer: Ismo Toijala <ismo.toijala@gmail.com>
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+# Contributor: Levente Polyak <anthraxx[at]archlinux[dot]org>
# Contributor: Daniel Micay <danielmicay@gmail.com>
# Contributor: Sébastien Luttringer <seblu@aur.archlinux.org>
# Contributor: Angel Velasquez <angvp@archlinux.org>
@@ -7,16 +9,34 @@
_pkgbase='rxvt-unicode'
pkgname='rxvt-unicode-fontspacing-noinc-vteclear-secondarywheel'
-pkgver=9.26
-pkgrel=3
-pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing, no increment resizing, clear patched to behave like VTEs (keep all lines) and secondaryWheel.'
-arch=('i686' 'x86_64')
+pkgver=9.31
+pkgrel=1
+arch=('x86_64')
url='http://software.schmorp.de/pkg/rxvt-unicode.html'
+pkgdesc='Unicode enabled rxvt-clone terminal emulator (urxvt) with fixed font spacing, no increment resizing, clear patched to behave like VTEs (keep all lines) and secondaryWheel.'
license=('GPL')
-depends=('rxvt-unicode-terminfo' 'libxft' 'libxt' 'perl' 'startup-notification' 'libnsl')
-optdepends=('gtk2-perl: to use the urxvt-tabbed')
+makedepends=(
+ 'libxt'
+ 'libxext'
+ 'libxmu'
+ 'signify'
+)
+depends=(
+ 'rxvt-unicode-terminfo'
+ 'libxft'
+ 'perl'
+ 'startup-notification'
+ 'libnsl'
+ 'libptytty'
+ 'libxext'
+ 'libxmu'
+)
+optdepends=('gtk2-perl: to use urxvt-tabbed')
source=(
- "http://dist.schmorp.de/rxvt-unicode/Attic/$_pkgbase-$pkgver.tar.bz2"
+ "$_pkgbase-$pkgver.tar.bz2::http://dist.schmorp.de/rxvt-unicode/$_pkgbase-$pkgver.tar.bz2"
+ "$_pkgbase-$pkgver.tar.bz2.signature::http://dist.schmorp.de/rxvt-unicode/$_pkgbase-$pkgver.tar.bz2.sig"
+ "$_pkgbase-$pkgver.pub::http://dist.schmorp.de/signing-key.pub"
+ 'perl-5.38.patch'
'urxvt.desktop'
'urxvtc.desktop'
'urxvt-tabbed.desktop'
@@ -31,6 +51,12 @@ provides=('rxvt-unicode')
conflicts=('rxvt-unicode')
prepare() {
+ # hacking around to validate with signify
+ mv -v "$_pkgbase-$pkgver.tar.bz2."{signature,sig}
+ signify -V -p "$_pkgbase-$pkgver.pub" -m "$_pkgbase-$pkgver.tar.bz2"
+
+ patch -d $_pkgbase-$pkgver -p1 < perl-5.38.patch # Locale fix for perl 5.38
+
cd $_pkgbase-$pkgver
patch -p0 -i ../font-width-fix.patch
patch -p0 -i ../line-spacing-fix.patch
@@ -44,6 +70,9 @@ build() {
cd $_pkgbase-$pkgver
# we disable smart-resize (FS#34807)
# do not specify --with-terminfo (FS#46424)
+ # do not specify --disable-frills (FS#77474)
+ # workaround ncurses --disable-root-access (FS#79143)
+ export TIC="/usr/bin/tic -o${srcdir}/terminfo"
./configure \
--prefix=/usr \
--enable-256-color \
@@ -69,38 +98,35 @@ build() {
--enable-xft \
--enable-xim \
--enable-xterm-scroll \
- --disable-pixbuf \
- --disable-frills
-
- cd doc
- make *.man.in
- cd ..
-
+ --disable-pixbuf
make
}
package() {
# install freedesktop menu
for _f in urxvt urxvtc urxvt-tabbed; do
- install -Dm644 $_f.desktop "$pkgdir/usr/share/applications/$_f.desktop"
+ install -Dm 644 ${_f}.desktop "${pkgdir}/usr/share/applications/${_f}.desktop"
done
- cd $_pkgbase-$pkgver
- # workaround terminfo installation
- export TERMINFO="$srcdir/terminfo"
- install -d "$TERMINFO"
- make DESTDIR="$pkgdir" install
+
+ cd ${_pkgbase}-${pkgver}
+ make DESTDIR="${pkgdir}" install
# install the tabbing wrapper ( requires gtk2-perl! )
sed -i 's/\"rxvt\"/"urxvt"/' doc/rxvt-tabbed
- install -Dm 755 doc/rxvt-tabbed "$pkgdir/usr/bin/urxvt-tabbed"
+ install -Dm 755 doc/rxvt-tabbed "${pkgdir}/usr/bin/urxvt-tabbed"
}
-md5sums=('18dd0b15e7f67478bf0a88b0fc5e8cd4'
- 'fec94dc986fa37ec380079d81de3e0b2'
- 'fac55f0a8404c86dad3e702146762332'
- '8a5599197568c63720e282b9722a7990'
- 'f6bb5770d2e7b06d88882513710a267d'
- 'd4e03127a0d3bbf2e173850770651b08'
- '1c85de8253b3a9002fabaaaccbdb51de'
- 'aead33ba3b08eeb251fb0c1427a4a024'
- '061b851e89e53a71d1afad6947c51ca7'
- '6e137593a69b4b584305f3d513e471bf')
+sha256sums=('aaa13fcbc149fe0f3f391f933279580f74a96fd312d6ed06b8ff03c2d46672e8'
+ 'afea78dc25db8cd15da9959baf347b0634f4ef62dd3eeaff0c0a3389986b6a3e'
+ '48ef5720d77a870f25737b8f66fe2c1f88a01810013df70cb8155add904288e4'
+ '4bec0bf559a2eb6649e077b220fe25f532a8bc3da98ac519bc72a39b223e2cc4'
+ '5f9c435d559371216d1c5b49c6ec44bfdb786b12d925d543c286b0764dea0319'
+ '91536bb27c6504d6cb0d33775a0c4709a4b439670b900f0c278c25037f19ad66'
+ 'ccd7c436e959bdc9ab4f15801a67c695b382565b31d8c352254362e67412afcb'
+ 'ee7ad6f56c22fa7379c1ac2594ff941bf7f99344152da0b813319d3dadd1395b'
+ '8d5f2ee9dae827b7a99757fd5432416927a31cde2093e3ad1aefee0987d6ab8d'
+ '0ee0434eb84b3ce1f62a4e02c0ba6d0940f4c62477e8982eb9219186feb393e3'
+ '64afd103527ce2cb2a8c51fefd815615afd0a63bbb810f2fb5ea38f6280def03'
+ '9df34ba141a9e32d785f63b050ab82e6e6c745b391c5b16e17bec4dcd4a2b087'
+ '70b2c60887df3b335cd9b26a8ec3964845f75cca98099c7c5a6be4fa74770f57')
+
+# vim: ts=2 sw=2 et:
diff --git a/clear.patch b/clear.patch
index 402287677a61..69167d0f3438 100644
--- a/clear.patch
+++ b/clear.patch
@@ -1,7 +1,8 @@
-diff -r 4399ffb6a87c -r 48f53e1cf599 src/command.C
---- a/src/command.C Sat Jan 21 13:57:22 2012 +0100
-+++ b/src/command.C Mon Apr 30 16:22:25 2012 +0200
-@@ -2869,6 +2869,10 @@
+diff --git a/src/command.C b/src/command.C
+index d212764..b1a5ab1 100644
+--- a/src/command.C
++++ b/src/command.C
+@@ -2913,6 +2913,10 @@ rxvt_term::process_csi_seq ()
return;
}
@@ -12,7 +13,7 @@ diff -r 4399ffb6a87c -r 48f53e1cf599 src/command.C
switch (ch)
{
/*
-@@ -2932,6 +2936,12 @@
+@@ -2976,6 +2980,12 @@ rxvt_term::process_csi_seq ()
case CSI_CUP: /* 8.3.21: (1,1) CURSOR POSITION */
case CSI_HVP: /* 8.3.64: (1,1) CHARACTER AND LINE POSITION */
@@ -25,7 +26,7 @@ diff -r 4399ffb6a87c -r 48f53e1cf599 src/command.C
scr_gotorc (arg[0] - 1, nargs < 2 ? 0 : (arg[1] - 1), 0);
break;
-@@ -2943,6 +2953,16 @@
+@@ -2987,6 +2997,16 @@ rxvt_term::process_csi_seq ()
break;
case CSI_ED: /* 8.3.40: (0) ERASE IN PAGE */
@@ -42,7 +43,7 @@ diff -r 4399ffb6a87c -r 48f53e1cf599 src/command.C
scr_erase_screen (arg[0]);
break;
-@@ -3086,6 +3106,16 @@
+@@ -3135,6 +3155,16 @@ rxvt_term::process_csi_seq ()
default:
break;
}
diff --git a/font-width-fix.patch b/font-width-fix.patch
index 3bc8ce04230d..17829c26aa24 100644
--- a/font-width-fix.patch
+++ b/font-width-fix.patch
@@ -1,18 +1,18 @@
---- src/rxvtfont.C.bukind 2007-11-30 14:36:33.000000000 +0600
-+++ src/rxvtfont.C 2007-11-30 14:39:29.000000000 +0600
-@@ -1171,12 +1171,21 @@
+--- src/rxvtfont.C.orig 2021-11-21 16:33:25.000000000 -0300
++++ src/rxvtfont.C 2023-08-02 01:22:01.978928240 -0300
+@@ -1304,12 +1304,21 @@
XGlyphInfo g;
XftTextExtents16 (disp, f, &ch, 1, &g);
-
-+/*
+
++/*
+ * bukind: don't use g.width as a width of a character!
+ * instead use g.xOff, see e.g.: http://keithp.com/~keithp/render/Xft.tutorial
+
g.width -= g.x;
-
+
int wcw = WCWIDTH (ch);
if (wcw > 0) g.width = (g.width + wcw - 1) / wcw;
-
+
if (width < g.width ) width = g.width;
+ */
+ int wcw = WCWIDTH (ch);
diff --git a/line-spacing-fix.patch b/line-spacing-fix.patch
index 8431c4fa0cb4..6eced372bba4 100644
--- a/line-spacing-fix.patch
+++ b/line-spacing-fix.patch
@@ -1,9 +1,9 @@
---- src/rxvtfont.C.orig 2011-07-20 22:19:29.878012201 -0300
-+++ src/rxvtfont.C 2011-07-20 22:19:33.634671723 -0300
-@@ -1237,11 +1237,22 @@
-
- FT_Face face = XftLockFace (f);
-
+--- src/rxvtfont.C.orig 2023-08-02 01:24:19.511500140 -0300
++++ src/rxvtfont.C 2023-08-02 01:24:19.834839535 -0300
+@@ -1276,11 +1276,22 @@
+ break;
+ }
+
+/*
+ * use ascent, descent and height from XftFont *f instead of FT_Face face.
+ * this somehow reproduces the behaviour of the line height as seen on xterm.
@@ -12,7 +12,7 @@
descent = (-face->size->metrics.descender + 63) >> 6;
height = max (ascent + descent, (face->size->metrics.height + 63) >> 6);
width = 0;
-
+
+ */
+
+ ascent = f->ascent;
@@ -21,5 +21,5 @@
+ width = 0;
+
bool scalable = face->face_flags & FT_FACE_FLAG_SCALABLE;
-
+
XftUnlockFace (f);
diff --git a/secondaryWheel.patch b/secondaryWheel.patch
index 3bb71b8557fb..be9bc00c860e 100644
--- a/secondaryWheel.patch
+++ b/secondaryWheel.patch
@@ -1,8 +1,8 @@
diff --git a/doc/rxvt.1.pod b/doc/rxvt.1.pod
-index 87042cd..9dfb861 100644
+index 169e104..4bb13b3 100644
--- a/doc/rxvt.1.pod
+++ b/doc/rxvt.1.pod
-@@ -417,6 +417,11 @@ B<secondaryScreen>.
+@@ -427,6 +427,11 @@ B<secondaryScreen>.
Turn on/off secondary screen scroll (default enabled); resource
B<secondaryScroll>.
@@ -14,7 +14,7 @@ index 87042cd..9dfb861 100644
=item B<-hold>|B<+hold>
Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
-@@ -1029,6 +1034,13 @@ option is enabled, scrolls on the secondary screen will change the
+@@ -1044,6 +1049,13 @@ option is enabled, scrolls on the secondary screen will change the
scrollback buffer and, when secondaryScreen is off, switching
to/from the secondary screen will instead scroll the screen up.
@@ -29,10 +29,10 @@ index 87042cd..9dfb861 100644
Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
diff --git a/src/command.C b/src/command.C
-index 153f0e1..df22652 100644
+index d212764..3b7e266 100644
--- a/src/command.C
+++ b/src/command.C
-@@ -2246,10 +2246,46 @@ rxvt_term::button_release (XButtonEvent &ev)
+@@ -2237,10 +2237,46 @@ rxvt_term::button_release (XButtonEvent &ev)
}
else
# endif
@@ -82,10 +82,10 @@ index 153f0e1..df22652 100644
break;
#endif
diff --git a/src/optinc.h b/src/optinc.h
-index d814035..a365037 100644
+index 09f9a26..c79a5be 100644
--- a/src/optinc.h
+++ b/src/optinc.h
-@@ -26,6 +26,7 @@
+@@ -27,6 +27,7 @@
def(cursorBlink)
def(secondaryScreen)
def(secondaryScroll)
@@ -94,10 +94,10 @@ index d814035..a365037 100644
def(cursorUnderline)
#if ENABLE_FRILLS
diff --git a/src/rsinc.h b/src/rsinc.h
-index 1483955..10f6642 100644
+index 682322c..6325057 100644
--- a/src/rsinc.h
+++ b/src/rsinc.h
-@@ -103,6 +103,7 @@
+@@ -104,6 +104,7 @@
#ifndef NO_SECONDARY_SCREEN
def (secondaryScreen)
def (secondaryScroll)
@@ -106,14 +106,14 @@ index 1483955..10f6642 100644
#if OFF_FOCUS_FADING
def (fade)
diff --git a/src/xdefaults.C b/src/xdefaults.C
-index 69acdd8..3e858de 100644
+index 2308844..0f5d2d0 100644
--- a/src/xdefaults.C
+++ b/src/xdefaults.C
-@@ -262,6 +262,7 @@ optList[] = {
+@@ -258,6 +258,7 @@ optList[] = {
#ifndef NO_SECONDARY_SCREEN
- BOOL (Rs_secondaryScreen, "secondaryScreen", "ssc", Opt_secondaryScreen, 0, "enable secondary screen"),
- BOOL (Rs_secondaryScroll, "secondaryScroll", "ssr", Opt_secondaryScroll, 0, "enable secondary screen scroll"),
+ BOOL (Rs_secondaryScreen, "secondaryScreen", "ssc", Opt_secondaryScreen, 0, "secondary screen"),
+ BOOL (Rs_secondaryScroll, "secondaryScroll", "ssr", Opt_secondaryScroll, 0, "secondary screen scroll"),
+ BOOL (Rs_secondaryWheel, "secondaryWheel", "ssw", Opt_secondaryWheel, 0, "enable secondary screen wheel"),
#endif
- #if ENABLE_PERL
- RSTRG (Rs_perl_lib, "perl-lib", "string"), //, "colon-separated directories with extension scripts"),TODO
+ #if ENABLE_FRILLS
+ STRG (Rs_rewrapMode, "rewrapMode", "rm", "string", "rewrap mode (auto, always, never)"),